Search bar ceases to work after accidentally copying a long string into it.

RESOLVED INVALID

Status

()

Firefox
Search
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Christian Szegedy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I accidentally copied a very long string (containing some houndred words) from a
webpage into the search-bar.

The following queries will never work, the new query string is appearently
attached to the end of the very long string and the concatenated string is sent
to the search engine. The problem seems to be that it is hard to delete the
whole string from the search bar.

One could theoretically delete the string by keeping the backspace pressed for
several minutes, but it would be tedious. Pressing home, and shift+End followed
by backspace does not kill the whole text, only a small part of it.

It is very hard to restore the functioning of the search bar without restarting
the browser.




 



Reproducible: Always

Steps to Reproduce:
1. Go to www.amazon.com
2. Copy and paste the whole page into the search bar. Do a search.
3. Try to get rid of the text in the search bar.

Actual Results:  
You can delete the text in the search var by iterating the 
following sequence of keystrokes:
Home + shift End + backspace + backspace,
but it is very tedious.

Especially misleading that after 
Home + shift End + backspace
the search bar seems to be empty and usable, 
but it will yield wrong results when being used.

Expected Results:  
Home + shift End + backspace + backspace 
should delete the search bar at once.

An empty looking search bar should be really empty.

Comment 1

13 years ago
Just hit Ctrl+a, then delete.

WFM Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050630
Firefox/1.0+ ID:2005063006

Updated

12 years ago
Blocks: 302294

Comment 2

11 years ago
This seems to be even less of an issue in 2.0 where only the first line is pasted.
FYI - Shift+End only ever does to the end of line. Home, Ctrl+Shift+End does what you were trying to do (as does Ctrl+A as Aaron points out)

Unless I'm missing something, this is INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
Summary: Search bar ceases to wark after accidentally copying a long string into it. → Search bar ceases to work after accidentally copying a long string into it.
You need to log in before you can comment on or make changes to this bug.