Closed Bug 299514 Opened 15 years ago Closed 14 years ago

Random unresponsive keyboard shortcuts and context menus

Categories

(Core :: DOM: UI Events & Focus Handling, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: krmathis, Assigned: jaas)

References

Details

(Whiteboard: [Fixed?] Have patch in bug 258285)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050702 Firefox/1.0+ (PowerBook)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050702 Firefox/1.0+ (PowerBook)

The 4-5 last days, since around the time CFRunLoop was turned on by default (
bug 298293 ), I have had problems with random unresponsive keyboard shortcuts
and context menus.

It goes like this:
Surfing with several tabs open, then I want to copy some text or a link. Select
some text and click ctrl-c, nothing happends. Select the same text and go to
Edit->Copy, just to find the choice all greyed out. Paste some text into a text
field dont work either.
At the same time I am unable to "Open Link in New Tab". The context menu have
the correct entry, but clicking on it does nothing.

When this happends I switch between tabs or menus for for a minute os so and it
"magically" works again. Or restart Firefox.


Its verified by 2 other people in the MozillaZine forum, but none of us have
found a pattern to reproduce it. It just seems to strike randomly.


Reproducible: Sometimes

Steps to Reproduce:
1. We are working on this one. But we have not found a good pattern yet...  :(

Actual Results:  
Keyboard shortcuts and context menus dont work

Expected Results:  
Keyboard shortcuts and context menus should work all the time


Hope its not a duplicate report.
Version: unspecified → Trunk
This happens also to me randomly. Yesterday I copied an url from the location
bar and tried to paste it into an input box of an other tab. I repeated the
copy-and-paste action several times in vain. When I pasted it first into a text
editor it finally succeeded.

Randomly I also miss the option Copy in my rightclick menu. 
Screenshot: http://img.photobucket.com/albums/v337/tamarix/Copy.jpg
Firefox seems to think that the selection is a link?

I can never reproduce it.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702
Firefox/1.0+ ID:2005070222 
Ooops, I refered to the wrong bug.
CFRunLoop is bug 282940 , bfast cache is bug 298293
I've had this problem for quite a while, especially with the 'Copy' and 'Paste'
keyboard shortcuts. Those problems are seemingly more frequent the past few
days. As Kai commented, it always happen very much at random. When this happens,
the following two things: selecting text on a page, attempting to copy via
cmd+C, should  copy *and* the 'Edit' menu should briefly blink or lighten up.
None happen.

Usually, I can go to the Edit menu and select Copy manually, which then works.
Subsequent attemps to copy then work correctly. Or just switching to another app
(email, text editor - it is when I notice that I didn't copy anything... - and
going back to Firefox).

I cannot really comment on the problem with the context menu. I've not had
problems with this, because either I use a multiple button mouse, or I have the
trackpad on my Powerbook configured to simulate the right click button (using
Sidetrack). I suspect here that the problem arise when triggering the context
menu by using the control key.

All this the nightly builds, running on OS X 10.3.9.
I've had that problem happen with Firefox 1.0x as well, very randomly.
I think this is a focus issue, see:

https://bugzilla.mozilla.org/show_bug.cgi?id=258285#c115

Condensed, it seems like Firefox gets confused about what tab is active and so
you're trying to do something (copy/paste, enter text into a form) and it's
looking at the wrong tab and either can't do what you want or does the wrong
thing (i.e. no text is selected in the tab it thinks is active, so nothing is
copied, or no form text entry field is active in that tab so it pops up the FAYT
bar).

I'm pretty sure this existed before the switch to CFRunLoop though that may have
made it more apparent.
(In reply to comment #4)

That sound right.
Cause when the bug strikes there are lots of problems, like it dont know which
tab is active.

Here are the problems I have found so far:
* Keyboards shortcuts dont work (cmd-c, cmd-v).
* Context menus dont work or displays wrong (copy/paste dont work, or "normal"
back/forward context menu show up when ctrl-click a link).
* Up and Down keys dont scroll page.
* Some keyboard combinations dont work in text forms (Ex. Shift-7 should type /
(norwegian keyboard), but opens FAYT instead).

Since its so inconsistent I have still not found a pattern to reproduce it. It
just strikes random every hour or two.
Bug 300340 shows, that this is not Firefox- or Mac-specific bug. Moving to Core.
Component: Keyboard Navigation → Keyboard: Navigation
Flags: blocking1.8b4?
OS: MacOS X → All
Product: Firefox → Core
Hardware: Macintosh → All
*** Bug 300340 has been marked as a duplicate of this bug. ***
Marking NEW (based on bug 258285 comment 115 and duplicated bug 300340).
Status: UNCONFIRMED → NEW
Ever confirmed: true
Comment #3 sounds like bug 220900
Some members have mentioned greyed out context menus while experiencing this
bug, but that is not the case for me.  Now, whether I go to edit, or use the
context menu, or use keyboard shortcuts I still am unable to copy text to the
clipboard.

On the other hand I have been able to cut the selected text to the clipboard.
Josh, can you dig into this and see if we can get a handle on it for b4?
Assignee: nobody → joshmoz
Josh: with "browser.sessionhistory.max_viewers" pref setted to non-zero value is
reproducibility much higher for me.
Without a reproducible testcase, we're not gonna get this for beta. Please
renominate if you can determine specific steps to trigger this state. 
Assignee: joshmoz → nobody
Flags: blocking1.8b4? → blocking1.8b4+
Whiteboard: CFRunLoop failout?
Someone please work to get a testcase for this, it's very important.
Question --- when the problem happens does pagedown seem to scroll the content
in a different tab?

(In reply to comment #12)
> Josh: with "browser.sessionhistory.max_viewers" pref setted to non-zero value 
> its reproducibility much higher for me.
This makes it sound related to bug 301804

It also sounds similar to bug 302139
*** Bug 303360 has been marked as a duplicate of this bug. ***
I am sorry, I came to CC list as someone marked my bug as a duplicate, and I
don't have any problem with this bug here (I have also reopend my bug 303360)
Assignee: nobody → joshmoz
Hopefully this is a reproducible testcase for this (it is for me on Win with
1.8b4 2005080506).  Bfcache on or off does not change it.

Launch 2 firefox processes by clicking on the icon twice.
In the second window get to any page that has more than one screen, (for example
abcnews.com).
In the second window the page up / page down keys do not work, (and copy is
missing from the context menu if you select some text and right click, and
ctrl-c has no effect).
Now click in the taskbar to another window (can be anything) and back to the
second firefox window, now the copy menu and page up and down works.
The testcase in comment 17 sounds like bug 258285. Is this the same bug as that?
Whiteboard: Have patch in bug 258285
Was this fixed by the checkin for bug 258285?
(In reply to comment #19)
> Was this fixed by the checkin for bug 258285?

On branch, the testcase from comment 17 now WFM with Windows NT 5.1 rv:1.8b4
Gecko/20050817 ID:2005081711.
Also I have not focus, FAYT or copy/paste issues with this build.
Whiteboard: Have patch in bug 258285 → [Fixed?] Have patch in bug 258285
Can anyone still reproduce this bug (or bug 220900)? I haven't seen this since
bug 258285 was fixed. Resolve WFM?
no longer blocking since we can't reliably reproduce
Flags: blocking1.8b5+
(In reply to comment #21)
> Can anyone still reproduce this bug (or bug 220900)? I haven't seen this since
> bug 258285 was fixed. Resolve WFM?

I had this problem yesterday again with SeaMonkey trunk 20050907. See bug 307375
for the reincarnation of bug 258285, that should (have) cause(d) it.
Also bug 299514 for loss of functionality. The symptoms in that bug are mostly gone on _my_ side, althought the copy/paste problem sometimes happen (again, randomly, which makes it very difficult to track).
Sorry about my last comment, was not meant for this bug.
QA Contact: keyboard.navigation → keyboard.navigation
I am marking this bug "Works for me", since I have not been able to reproduce the last year (or so). 
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.