Completed .xxx address changes when tabs are switched

RESOLVED DUPLICATE of bug 287996

Status

()

RESOLVED DUPLICATE of bug 287996
14 years ago
14 years ago

People

(Reporter: rudy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702 Firefox/1.0+

This bug is noted in Deer Park Alpha 1 release and still there in the version
grabbed on July 2 2005 from nightly builds.

When you enter an address and invoke .ext auto-completion, Firefox completes the
URL. However, if you switch tabs before allowing the page to loads, and the
switch back to that tab, the completed address in the location bar reverts back
to the typed one.

Reproducible: Always

Steps to Reproduce:
1. Have 2 tabs open in Deer Park.
2. Type microsoft, and press Ctrl+Enter to invoke auto-completion.
3. Before the page starts loading, switch to the other tab using Ctrl+Tab.
4. Switch back quickly to the tab that you were on.

Actual Results:  
The word "microsoft" appears in the location bar.

Expected Results:  
The URL: http://www.microsoft.com should appear.

This appears on Windows XP and Windows 2003. I'm using the default theme, and
all extensions that modify tab behaviors were disabled when experiencing the bug.
(Reporter)

Comment 1

14 years ago
This also applies when you select a URL using the auto-complete dropdown that
shows while typing a URL in the address bar.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 287996 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.