Last Comment Bug 299538 - l10n CVS account request: Malayalam(ml-IN) - Joyce K. Babu<joycekbabu@gmail.com>
: l10n CVS account request: Malayalam(ml-IN) - Joyce K. Babu<joycekbabu@gmail.com>
Status: RESOLVED FIXED
voucher, ssh-key, form
:
Product: mozilla.org
Classification: Other
Component: Repository Account Requests (show other bugs)
: other
: x86 Windows XP
: -- normal (vote)
: ---
Assigned To: matthew zeier [:mrz]
: Dave Miller [:justdave] (justdave@bugzilla.org)
Mentors:
Depends on: 290869
Blocks:
  Show dependency treegraph
 
Reported: 2005-07-03 08:38 PDT by Joyce K Babu
Modified: 2007-05-18 08:04 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
SSH public key (616 bytes, text/plain)
2005-07-09 00:34 PDT, Joyce K Babu
no flags Details
Localized files (656.70 KB, patch)
2005-08-05 11:57 PDT, Joyce K Babu
no flags Details | Diff | Review
Malayalam Localization (224.00 KB, application/zip)
2006-07-22 09:32 PDT, Joyce K Babu
l10n: approval‑l10n+
Details
New SSH Key (616 bytes, text/plain)
2006-07-25 10:38 PDT, Joyce K Babu
no flags Details
My SSH public key (rsa) (223 bytes, application/octet-stream)
2007-01-31 22:53 PST, Praveen A
no flags Details

Description Joyce K Babu 2005-07-03 08:38:41 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Win98; ml-IN; rv:1.7.6) Gecko/20050317 Firefox/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ml-IN; rv:1.7.6) Gecko/20050317 Firefox/1.0.2

CVS account request for Joyce K. Babu, member of the Malayalam localization team
for Firefox(versions 1.0.2 and 1.1)

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Comment 1 Marcia Knous [:marcia - use ni] 2005-07-05 11:25:17 PDT
Need a CVS form to start the proces - www.mozilla.org/hacking/form.html.  You
will need a voucher as well as an SSH key.
Comment 2 Zibi Braniecki [:gandalf][:zibi] 2005-07-08 13:43:37 PDT
Joyce: are you going to be an owner of ml-IN team?
Comment 3 Joyce K Babu 2005-07-09 00:28:56 PDT
> Joyce: are you going to be an owner of ml-IN team?
I am the team leader
Comment 4 Joyce K Babu 2005-07-09 00:34:32 PDT
Created attachment 188750 [details]
SSH public key
Comment 5 Joyce K Babu 2005-07-16 09:06:43 PDT
fax sent
Comment 6 Marcia Knous [:marcia - use ni] 2005-07-17 15:04:20 PDT
fax received.
Comment 7 Joyce K Babu 2005-07-30 11:47:36 PDT
I haven't received any response to my request all these days.. is this delay 
usual ? or is it b'coz of some fault from our part ? plz reply...
thanx
Comment 8 Marcia Knous [:marcia - use ni] 2005-07-30 19:52:36 PDT
Joyce: someone needs to vouch for you in this bug before I can activate your account.  
Comment 9 Joyce K Babu 2005-07-31 10:58:09 PDT
Yeah,I know that. But how do I get someone to vouch for me ? 
Comment 10 Marcia Knous [:marcia - use ni] 2005-08-03 13:47:32 PDT
Joyce: Once gandalf, bsmedberg or someone in l10n reviews your code, they should
be able to evaluate your code and give me the approval to activate your account.
Comment 11 Zibi Braniecki [:gandalf][:zibi] 2005-08-03 23:22:00 PDT
Joyce: please, attach zipped localization directories to this bug so I can
review them. (directory structure for trunk. Like -
http://lxr.mozilla.org/l10n/source/)
Comment 12 Joyce K Babu 2005-08-05 11:57:14 PDT
Created attachment 191721 [details] [diff] [review]
Localized files

Attaching the localized files
Comment 13 Joyce K Babu 2005-08-12 12:49:49 PDT
I have attached the localized files as instructed. I hope the files will be 
reviewed. Hope I'll get an early reply.

Joyce
Comment 14 Joyce K Babu 2005-09-11 11:02:05 PDT
Is this the correct directory structure? it has been downloaded from
cvs-mirror.mozilla.org:/l10n co l10n/pl..
Comment 15 Joyce K Babu 2005-10-29 12:36:40 PDT
The new localization files are uploaded at
http://prokerala.com/mozilla/ml-IN.zip . Please review the files. The base files
were downloaded from :pserver:anonymous@cvs-mirror.mozilla.org:/l10n co l10n/en-GB
Comment 16 Joyce K Babu 2005-11-11 05:36:31 PST
I have localized about a thousand strings. Plz review. The files are uploaded at http://prokerala.com/mozilla/ml-IN.zip
Comment 17 Joyce K Babu 2005-11-30 04:57:19 PST
I have completed localizing. Please review.
Comment 18 Zibi Braniecki [:gandalf][:zibi] 2005-11-30 06:22:58 PST
I'm on it
Comment 19 Joyce K Babu 2005-12-25 12:55:09 PST
Can I know whether the review process is still on?
Comment 20 Joyce K Babu 2006-01-07 10:44:30 PST
Hellooo! Can I know what is making the delay?
Comment 21 Marcia Knous [:marcia - use ni] 2006-01-11 10:49:36 PST
Joyce: This still has a voucher needed in the status whiteboard, need someone to bless it before I create your account.
Comment 22 Joyce K Babu 2006-02-09 07:58:27 PST
We are terribly disappointed to see that no one has vouched for us even after such a long period. We started localizing Mozilla with the great expectation and  hope that some day we will be able to dedicate the Malayalam Firefox browser and at the same time be a part (atleast a very small) of this(Mozilla) great foundation. But this delay and avoidance is downing our spirits. Is this delay because no new localizations are accepeted?? We started this project almost a year back.
Joyce
Comment 23 Axel Hecht [:Pike] 2006-02-14 12:40:44 PST
I'd like to know which version this localization is for, checking against the 
MOZILLA_1_8_0_BRANCH gives lots of errors, which is the branch that firefox 1.5
is on.

I see quite a few english strings glancing over the files, too.
bookmarks.html is empty, search engines are not localized, please take a 
look at http://wiki.mozilla.org/L10n:Firefox_Extras for more information on the
guidelines here.

Do you use Mozilla Translator or a descent tool/editor? I'm asking because of the
encoding of properties files, those can (and should) be just plain utf-8, not
the \u0000 foo anymore.
Comment 24 Joyce K Babu 2006-02-15 13:29:19 PST
>I'd like to know which version this localization is for
Deer Park Alpha 2. I downloaded the original files from :pserver:anonymous@cvs-mirror.mozilla.org:/l10n co l10n/en-GB on october 20. I used the locale en-GB b'coz i had trouble downloading en-US files.

>I see quite a few english strings glancing over the files, too.
Due to lack of proper unicode support, some english strings when translated are difficult to read. We will do our best to find an alternative. 

>bookmarks.html is empty, search engines are not localized
I am sorry. We will translate and upload the latest files at the earliest.

>Do you use Mozilla Translator or a descent tool/editor?
I use Mozilla Translator 5.04. Some of the files exported from MT when compared (with compare-locales.pl) with the original en-GB files gave many errors. Hence I manually edited those files using my text editor. Could you plz tell me if there is any other tool that I should use.
Comment 25 Axel Hecht [:Pike] 2006-02-26 02:32:20 PST
Joyce, I hacked MT to generate utf-8 encoded property files, you can find the
test build at
http://www.axel-hecht.de/l10n/mt505pl1.jar.

If you upload another version, please make something up to par with the 
MOZILLA_1_8_0_BRANCH?

cvs -d:pserver:anonymous@cvs-mirror.mozilla.org:/l10n co -r MOZILLA_1_8_0_BRANCH l10n/en-GB 

gives you a tree to compare to.
Comment 26 Joyce K Babu 2006-02-26 06:23:21 PST
Thankyou for the reply and the tool. I am having my exams now. It will be over in 2 weeks. Once over I will translate the entire files once again and upload them at  the earliest. 
Comment 27 Marcia Knous [:marcia - use ni] 2006-07-03 14:35:51 PDT
Joyce: Do we have a status update on this bug? Looks as if your last comment was back in February.
Comment 28 Joyce K Babu 2006-07-04 04:22:16 PDT
I am sorry that I couldn't inform. Soon after my exams, I was out of station for 3 month. On returning I got little busy with another project and I almost forgot about completing this. It is almost finished and just needs a few final touches. I terribly sorry for this mistake and will surely complete and upload the files within a week.
Comment 29 Axel Hecht [:Pike] 2006-07-04 04:30:03 PDT
An additional comment/warning. We're closing out on Firefox 1.5 in terms of new locales, as 2.0 is just around the corner. For the purpose of this review, I'm not that picky which you submit, but I just want to tell you beforehand that there is virtually no route for further new locales on the 1.5.0.x release cycle.
Comment 30 Joyce K Babu 2006-07-04 05:09:58 PDT
Then shall I stop working on version 1.5 and start translating version 2.0 ? Will I be able to download the localization files from MOZILLA_1_8_0_BRANCH ? If not can you plz tell me where to download it?
Comment 31 Axel Hecht [:Pike] 2006-07-04 05:19:42 PDT
I suggest working on 2.0, yes. You can get the sources from the MOZILLA_1_8_BRANCH. You may find bug 339000 useful, too, which should give you a bootstrap on what needs to be changed overall.
Comment 32 Joyce K Babu 2006-07-22 09:32:17 PDT
Created attachment 230270 [details]
Malayalam Localization

Uploading the localized files for Malayalam Firefox(Bon Echo). Please review it.
Comment 33 Axel Hecht [:Pike] 2006-07-25 05:26:43 PDT
Comment on attachment 230270 [details]
Malayalam Localization

There are a bunch of untranslated strings in there, but the general structure is ok.
Comment 34 Axel Hecht [:Pike] 2006-07-25 05:29:41 PDT
Vouching.
Marcia, I think this is ready to go.

Joyce, once this is up, you should land on the trunk first, and make sure that your line endings etc are right.
I'll double check then and then we should branch to the 1.8 branch. I'm not sure if this will be in time for 2.0, I expect this to take 'til a minor release, as a heads up.
Comment 35 Joyce K Babu 2006-07-25 06:01:55 PDT
Thanks a lot for vouching. I am sorry, I forgot the password I used for creating the SSH Key. Can I attach another key?
Comment 36 Axel Hecht [:Pike] 2006-07-25 06:30:02 PDT
Comment on attachment 188750 [details]
SSH public key

marking old key obsolete, and please attach a new key
Comment 37 Joyce K Babu 2006-07-25 10:38:07 PDT
Created attachment 230596 [details]
New SSH Key

Attaching the new SSH Key.
Comment 38 Marcia Knous [:marcia - use ni] 2006-07-28 11:19:40 PDT
Looks like everything is in place for this one. Over to server-ops for account creation.
Comment 39 matthew zeier [:mrz] 2006-07-28 11:43:22 PDT
Your CVS account has been created.  Your CVSROOT should be:

   joycekbabu%gmail.com@cvs.mozilla.org:/cvsroot

Don't forget to set your CVS_RSH environment variable to 'ssh'.

If you have any problems connecting, let me know.
Comment 40 Reed Loden [:reed] (use needinfo?) 2006-07-28 11:45:50 PDT
(In reply to comment #39)
>    joycekbabu%gmail.com@cvs.mozilla.org:/cvsroot

Wrong repository. He needs access to /l10n on cvs, not /cvsroot.

Comment 41 matthew zeier [:mrz] 2006-07-28 11:52:43 PDT
(In reply to comment #40)
> (In reply to comment #39)
> >    joycekbabu%gmail.com@cvs.mozilla.org:/cvsroot
> 
> Wrong repository. He needs access to /l10n on cvs, not /cvsroot.
> 

My bad - should be fixed now.
Comment 42 Joyce K Babu 2007-01-13 09:54:24 PST
I'm sorry that i got deviated from this project. I didn't know what to do next. I tried to contact others at the l10n IRC but i was unable to get proper guidence as to how to proceed. I don't know how to connect to CVS repository using my cvs client (cvs tortoise). I tried to get help from IRC, but all users i contacted were using linux, so they couldn't help me. I sent a mail to Marcia requesting guidance, but i received no reply and very i'm sorry i got diverted from this project. I am very much interested in the completion of this project. It will be of great help if someone could advise me as to how i can revive and complete this project.
Comment 43 Praveen A 2007-01-31 22:48:22 PST
Hi,

I have joined the team and would like to get cvs access (Joyce seems to have difficulty in getting cvs to work for him).

I'm attaching my ssh public key.

Cheers
Praveen
Comment 44 Praveen A 2007-01-31 22:53:20 PST
Created attachment 253575 [details]
My SSH public key (rsa) 

My (Praveen) ssh key
Comment 45 Reed Loden [:reed] (use needinfo?) 2007-01-31 23:15:52 PST
Praveen: You can't use this bug to get access. If you want to get CVS access, you'll have to follow the same steps everybody else has to follow. Check out http://www.mozilla.org/hacking/getting-cvs-write-access.html for more information.
Comment 46 Joyce K Babu 2007-02-01 01:16:08 PST
I have finally sorted everything out. Now I will be committing the localization to the repository soon.
Comment 47 Axel Hecht [:Pike] 2007-02-01 01:29:25 PST
Joyce, good to hear.

Praveen, if Joyce and you think it'll be good for the Malayalam localization for you to have cvs access, please file a CVS account bug. CC both me and Joyce and get Joyce to vouch. You need to fill out the CVS form, too, but the vouching is a little bit adapted for l10n accounts.

I'll back up the vouching by Joyce, though I may wait for the initial commit for Joyce to be locale owner in practice.
Comment 48 Axel Hecht [:Pike] 2007-02-01 02:59:08 PST
As discussed with Joyce, we're going for 'ml' as locale name, the '-IN' is not needed for Malayalam.

Note You need to log in before you can comment on or make changes to this bug.