Cache content being saved in a folder different from the profile; breaks pre-Deer Park profiles; may be StumbleUpon or other extension issue

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: unquietwiki, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b2) Gecko/20050702 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b2) Gecko/20050702 Firefox/1.0+

The user profiles & caches have historically been stored here...

C:\Documents and Settings\(username)\Application
Data\Mozilla\Firefox\Profiles\(profile name)\(cache)

However, since using the 7-2-2005 nightly for Deer Park, even after purging the
profile content & this new folder, Deer Park still puts all the cache content in
the following folder...

C:\Documents and Settings\(username)\Local Settings\Application
Data\Mozilla\Firefox\Profiles\(profilename)\Cache

This also seems to cause inexplicable back button, forward button, and location
bar errors if you don't delete the old profile data beforehand.


Reproducible: Sometimes

Steps to Reproduce:
1. Download & install the Deer Park 7-2-2005 nightly (I used the ZIP version).
2. Begin surfing different webpages without deleting anything from the profile
folders.

Actual Results:  
Back and forward will have random glitches; address bar may not update to new
sites visited.

Expected Results:  
In the past, upgrading to a nightly in this fashion hasn't caused the errors
described above.
(Reporter)

Comment 1

13 years ago
When using the StumbleUpon extension, the location bar will not update, even
when back or forward is clicked. I'm not sure if this is connected to this error
or not.
The cache location was moved intentionally in bug 291033 to improve support for
network deployments.

Could you be more specific about the cache problems? What build were you using
before you upgraded to the 7-2-2005 nightly?

Do the problems disapear once you clear the cache?


Given comment 1, do the problems occur in safe mode?
(Reporter)

Comment 3

13 years ago
1. I'm noticing additional random failures of the "back" button to appear on
pages: I know there's a bug with Google Mail having some trouble; regular Google
searches seem to have a problem with "back" as well.

2. Clearing cache in normal mode does not resolve the problems.

3. Safe mode does not seem to have any trouble so far.
(Reporter)

Comment 4

13 years ago
Oh yeah, I was using Firefox 1.0.4 before the upgrade. I test different builds,
one at a time, so whenever I delete the profile, I delete everything but the
bookmark, signon, and cookie files (3 total). I'm wondering if maybe the back &
forward aren't calling from the new cache location, or the extensions for that
matter.
Depends on: 291033
> 3. Safe mode does not seem to have any trouble so far.

This suggests that it is an extension problem which would make this bug invalid.

Can you narrow the problem down to being caused by a specific extension?
(Reporter)

Comment 6

13 years ago
http://bugs.stumbleupon.com/show_bug.php?bugid=39

I believe on my end it is StumbleUpon 2.01 causing it; I suspect it may be the
changed cache location or the new back-forward enhancements breaking it; I
submitted a bug report to them. Anyone have any further observations or ideas?
Any other extensions that induce the changing of pages (Coralize extension works
fine)?
Summary: Cache content being saved in a folder different from the profile; breaks pre-Deer Park profiles → Cache content being saved in a folder different from the profile; breaks pre-Deer Park profiles; may be StumbleUpon or other extension issue
With the cache in my profile I can still see Bug 298928; makes no difference. 

Comment 8

13 years ago
If you can't reproduce this bug without any extensions (you should not be filing
bugs unless you /have/ done this is the first place...) then it's INVALID. And
judging from the reporter's comments comment 3 and comment 4, this seems to be
the case.
This appears to be a problem with the stumbleupon extension. Therefore resolving
Invalid.

I am unable to access http://bugs.stumbleupon.com/show_bug.php?bugid=39 but
presume this is the same bug report to stumbleupon, if not please report this
isuse to them.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

13 years ago
Here's the odd part: you need to have the extension installed to be able to log
into the bug report. (shakes head)
You need to log in before you can comment on or make changes to this bug.