FireFox is not listening to PHP Header Output

VERIFIED INVALID

Status

()

Core
Networking: HTTP
--
major
VERIFIED INVALID
13 years ago
13 years ago

People

(Reporter: Tom, Assigned: Darin Fisher)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Try the following in a test PHP script...

[?php
header("HTTP/1.0 403 Forbidden");
?]Test Page

If you pull that up that FireFox, it will show the page with the text "Test
Page" on it.  Pull it up in Internet Explorer and you will get the proper error
message.

Reproducible: Always

Steps to Reproduce:
1. Create test PHP page with code in Details.
2. View page in browser
3. See no error.

Actual Results:  
I get a web page.

Expected Results:  
Give me an HTTP 403 Forbidden error message.
I think that this bug is invalid. IE shows per default not the error text from
the server while Gecko is doing that. IF you specify an error message, Necko
will show that.

-> http (unsure if I'm right)
Assignee: nobody → darin
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Version: unspecified → 1.0 Branch
invalid per rfc2616 ("User agents SHOULD display any included entity to the user.")

(disable "show sort http error messages" in the IE options to get the same with IE)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID

Comment 3

13 years ago
Verified. Gecko uses the text in the content as the error-page, because it's
supposed to be a nicely formatted message for the user (what went wrong, who to
contact, etc ...)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.