fix libmar cross-compile bustage (mingw)

RESOLVED FIXED in mozilla1.8beta3

Status

defect
RESOLVED FIXED
14 years ago
Last year

People

(Reporter: cls, Assigned: cls)

Tracking

Trunk
mozilla1.8beta3
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

This is a spinoff from bug 296303.
Cleaned version of previous patches:
- Moves HOST_AR_FLAGS into configure.in
- Adds HOST_OS_ARCH to better handle the native build case
- Exposes autoconf standard host_cpu, host_vendor, host_os variables
- Always build native version of libmar & mar tool

Tested linux->mingw & native mingw/freevc builds.
Attachment #188123 - Flags: review?(benjamin)
Comment on attachment 188123 [details] [diff] [review]
mingw + cross-compile fixes v3

Please land this expeditiously ;-)
Attachment #188123 - Flags: review?(benjamin)
Attachment #188123 - Flags: review+
Attachment #188123 - Flags: approval1.8b3+
This appears to have broken the Firefox win32 'beast' tinderbox.
pacifica broke as well, but with a pdb collision error.  It's like the win32
build rules are being forgotten in libmar's build.
Attachment #188354 - Flags: review?(chase)
Attachment #188354 - Flags: approval1.8b3?
Comment on attachment 188354 [details] [diff] [review]
fix msvc build bustage

a=chase to fix build bustage.  Thanks Darin.  cls, maybe you can take another
pass at your mingw fix when you have a minute.
Attachment #188354 - Flags: review?(chase)
Attachment #188354 - Flags: review+
Attachment #188354 - Flags: approval1.8b3?
Attachment #188354 - Flags: approval1.8b3+
'fix msvc build bustage' patch is in on the trunk
FYI, that's the same bustage that I asked about in bug 297124, which I thought I
was hitting locally without the cross-compile fixes.  The fix has no affect on
mingw builds, which do not use WIN32_EXE_LDFLAGS.
The .pdb file conflict is because pacifica is doing a parallel build and
PDBFILE isn't being used for $host builds.
Attachment #188366 - Flags: review?(chase)
Comment on attachment 188366 [details] [diff] [review]
Add -Fd$(HOST_PDBFILE) to HOST_CFLAGS

>Index: config/rules.mk
>===================================================================
>RCS file: /cvsroot/mozilla/config/rules.mk,v
>retrieving revision 3.481
>diff -u -r3.481 rules.mk
>--- config/rules.mk	5 Jul 2005 20:37:25 -0000	3.481
>+++ config/rules.mk	5 Jul 2005 22:19:48 -0000
>@@ -220,6 +220,10 @@
> endif # ENABLE_CXX_EXCEPTIONS
> endif # WINNT
> 
>+ifeq (,$(filter-out WINNT WINCE,$(HOST_OS_ARCH)))
>+HOST_PDBFILE=$(basename $(@F)).pdb
>+endif
>+

Could you add a comment above where PDBFILE is set in rules.mk mentioning that
any changes to how the PDBFILE name is chosen should be mirrored for
HOST_PDBFILE?  With that, r=chase.
Attachment #188366 - Flags: review?(chase) → review+
The patch has been checked in.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.8beta3
Causing further build breakage in VS 2003? Regression?
https://bugzilla.mozilla.org/show_bug.cgi?id=300123
No longer blocks: 300123
Blocks: 300123
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.