MathML with style "visibility:hidden" doesn't hide horiz lines

VERIFIED DUPLICATE of bug 275823

Status

()

Firefox
General
--
trivial
VERIFIED DUPLICATE of bug 275823
13 years ago
13 years ago

People

(Reporter: Ken Harris, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21 (Debian package 1.3.21-6)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050610 Firefox/1.0.4 (Debian package 1.0.4-3)

If I put a <math> inside a <div style="visibility: hidden">, the entire <math>
object is hidden, *except* for horizontal lines.  That is, the bar on the top of
an <msqrt> and the bar of an <mfrac> aren't hidden by CSS.

I will try to attach a simple example.

Reproducible: Always

Steps to Reproduce:
1. Write some MathML, using <msqrt> or <mfrac>
2. Put it in a block with style "visibility: hidden"

Actual Results:  
The equation disappeared, except for the horizontal bars of the <msqrt> and <mfrac>.

Expected Results:  
The equation should disappear completely.
(Reporter)

Comment 1

13 years ago
Created attachment 188130 [details]
Quadratic equation in MathML, with visibilyt:hidden
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050702
Firefox/1.0+ ID:2005070215

WFM I see a blank page

Ken, 1.0.4 is rather old (~ 1 year in core technology) can you please test with
a trunk nightly build to see if this problem has been fixed.
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 275823 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
v. dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.