Any download pauses when mouse clicked on title bar (and not released)

RESOLVED DUPLICATE of bug 282940

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 282940
13 years ago
13 years ago

People

(Reporter: Milesh Kumar, Unassigned)

Tracking

1.0 Branch
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I just noticed this on Firefox 1.0.4 on Mac OS X (10.4.1). Either of the two
scenarios below can be used to simulate the issue:
- first scenario - while a download is going on (and the download window is open
showing the progress), if the mouse button is clicked and held down (not
released) on any other Firefox window **title bar**, the download pauses until
the mouse button is released!

- second scenario - the user visits a web page that takes noticeable time to be
downloaded completely. If, during the page download, the user clicks on the
**title bar** of the window and holds the mouse button down (without releasing
it), the page download will pause until the mouse button is releaed.


What this means is that if you're downloading something (a normal web page or a
huge file) and you decide to move the Firefox window by clicking, holding down
the mouse button and dragging the window, the download would come to a
standstill until you have released the mouse button. Of course, normally you may
not lose more than a few seconds, but for some reason you just hold the mouse
clicked on the title bar and do not release it, you'd be unintentionally
delaying your downloads!

This is a bug that does not happen in the Windows build of Firefox 1.0.4 nor on
other Mozilla browsers, like Camino.

The workaround for this is to not click on the title bar and hold down the mouse
button for long while a download (of a web page or a file) is going on.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox on Mac OS X (10.4.1 is what I use)
2. Start downloading a big file (like Firefox for Mac, from
http://download.mozilla.org/?product=firefox-1.0.4&os=osx&lang=en-US)
OR
visit a web page that takes noticeable time to download (something with a lot of
graphics would help)
3. Depending on what's being attempted, the download window opens and shows the
download progress or the web page starts downloading and rendering
4. If downloading a file, change the focus to the main Firefox window OR if
downloading a web page stay on the same window.
5. Click on the title bar of the Firefox window with the mouse and hold it -
don't release the mouse button!

Actual Results:  
The file download happening in the download window OR the web page download
that's going on pauses until the mouse button is released.

Expected Results:  
The download of the file or the web page should proceed in parallel as it does
in the Windows build of Firefox and in Camino on Mac. It should not pause
because of the mouse being clicked and held on the title bar of any other
Firefox window.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.0 Branch

Comment 1

13 years ago
Probably related to bug 269388

Comment 2

13 years ago
Related to Core bug 141710?

Comment 3

13 years ago
This was a by-product of WaitNextEvent handling, and was mostly fixed by
changing to CFRunLoopSource.  Bug 282940 and bug 271050.  The application no
longer gets stuck while the user is playing around in the menus.

*** This bug has been marked as a duplicate of 282940 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.