Box of embedded plugin grows indefinetely

VERIFIED DUPLICATE of bug 295527

Status

VERIFIED DUPLICATE of bug 295527
14 years ago
4 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

({regression, testcase})

Trunk
x86
All
regression, testcase

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

199 bytes, text/html
Details
(Reporter)

Description

14 years ago
Just load the following URI and see the extremly growing of the plugin box.

http://www.bretz.de/index.asp?VCL=5

Confirmed with: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b2) Gecko/20050702
Firefox/1.0+ and Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b2)
Gecko/20050531 Firefox/1.0+
I see the same on WinXP. When I set plugin.default_plugin_disabled to false it
does not happen.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050703
Firefox/1.0+ ID:2005070323

Comment 2

14 years ago
Created attachment 188219 [details]
simplified testcase

created a simplified testcase
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> created a simplified testcase

Thank you for supplying the testcase. I have simplified it much more.
(Reporter)

Comment 4

14 years ago
Created attachment 188223 [details]
simplest testcase
Attachment #188219 - Attachment is obsolete: true
(Reporter)

Comment 5

14 years ago
This doesn't appear for Aviary builds. So mark regression.
Keywords: regression
Anyone have an idea of what's happening here?  I don't think this is common
enough to block b3, but we should fix for b4.  This is a trunk regression, and
the following bits probably are to blame/not working in this case:
http://lxr.mozilla.org/seamonkey/source/layout/generic/nsObjectFrame.cpp#1030
Flags: blocking1.8b4?
Depends on: 295527
I've tested the patch attached in bug 295527, this bug will also be fixed with it.

*** This bug has been marked as a duplicate of 295527 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED

Updated

13 years ago
Flags: blocking1.8b4?
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
(Assignee)

Updated

4 years ago
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.