In the Download Actions dialogue, when the MIME Type column is shown, the Action column cannot be resized

RESOLVED FIXED in Firefox 3

Status

()

Firefox
Preferences
P4
minor
RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: gkn, Assigned: Adam Guthrie)

Tracking

Trunk
Firefox 3
Points:
---
Bug Flags:
blocking1.8b5 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050703 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050703 Firefox/1.0+

In Tools > Options > Downloads > Download Actions > View & Edit Actions, the
Action column cannot be resized by dragging the column dividers. This only
applies when the MIME Type column is shown; by default it's hidden and this bug
does not occur.

Reproducible: Always

Steps to Reproduce:
1. Tools > Options > Downloads > Download Actions > View & Edit Actions
2. Click the choose columns to show icon, above the vertical scroll bar
3. Check MIME Types
4. Try to resize the Action column by dragging the divider at the left side of
its column header
Actual Results:  
The divider cannot be dragged

Expected Results:  
Dragging the divider should resize the columns as usual
(Assignee)

Comment 1

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050704
Firefox/1.0+ ID:2005070405

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

12 years ago
Flags: blocking1.8b4?

Comment 2

12 years ago
Would approve low-risk fix - but don't think this is severe enough to block the
beta release.
Flags: blocking1.8b4? → blocking1.8b4-

Comment 3

12 years ago
Hmmm... still id Deer Park

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060105 
Firefox/1.6a1
(Assignee)

Comment 4

12 years ago
Created attachment 207697 [details] [diff] [review]
patch

So basically what's happening is that the Actions column gets the <splitter> when MIME Type column is hidden, but when the MIME Type column is unhidden the Actions column is left without a <splitter>.

Seems like the <splitter> should be hidden when its neighboring column is hidden, but that's probably another bug.

I took off the flex="true" because it was misspelled and not doing anything. This is keeping the same behavior of not resizing the File Type column when the window gets resized, which makes sense to me.
Assignee: nobody → ispiked
Status: NEW → ASSIGNED
Attachment #207697 - Flags: review?(mconnor)
(Assignee)

Updated

12 years ago
OS: Windows XP → All
Priority: -- → P4
Hardware: PC → All
Target Milestone: --- → Firefox 2
Version: unspecified → 1.5 Branch

Updated

12 years ago
Attachment #207697 - Flags: review?(mconnor) → review+
(Assignee)

Comment 5

12 years ago
Created attachment 207698 [details] [diff] [review]
patch for Thunderbird

Same fix as for Firefox, just "ported" to Thunderbird's fork. :) See comment 4 for explanation.
Attachment #207698 - Flags: review?(mscott)
Checking in downloadactions.xul;
/cvsroot/mozilla/browser/components/preferences/downloadactions.xul,v  <--  downloadactions.xul
new revision: 1.9; previous revision: 1.8
done

Updated

12 years ago
Attachment #207698 - Flags: review?(mscott) → review+
mozilla/mail/components/preferences/downloadactions.xul; new revision: 1.5;
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 2 → Firefox 3
Version: 1.5 Branch → Trunk
Duplicate of this bug: 379681
You need to log in before you can comment on or make changes to this bug.