rfc822 type attachment always contains itself, causing an infinite loop

RESOLVED DUPLICATE of bug 203570

Status

RESOLVED DUPLICATE of bug 203570
14 years ago
13 years ago

People

(Reporter: atus, Assigned: mscott)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705)
Build Identifier: version 1.0.2 (20050317)

If you open an rfc822 type attachment, you allways got the message itself in 
its attachment list. It is very confusing, when the "original" letter also had 
attachments, even rfc822 messages too.

Reproducible: Always

Steps to Reproduce:
1. Create a mail with a fey line in the body and has no attachment. Send it to 
yourself.
2. Forward this mail as an attachment to yourself again.
3. Open the second mail.
4. Open the attachment which should not have any attachment. (because this was 
your first e-mail)
At this point, you see the attached letter as an attachment of itself.
You will never reach the end of the self loop.

Actual Results:  
Infinite loop. In a real life situation, you will never know what attachmant 
real, and what is not.

Expected Results:  
:) Filter the opened rfc822 message part from attachment list. (or probably 
clear the attachment list, before adding the new letter's attachments)
(Reporter)

Comment 1

14 years ago
Created attachment 188180 [details]
simple sample mail, which reproduce the problem

Comment 2

14 years ago
This looks like a duplicate of bug 203570.

Updated

14 years ago
Summary: rfc822 type attachment allways contains itself, causing an infinite loop → rfc822 type attachment always contains itself, causing an infinite loop
Version: unspecified → 1.0

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 203570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.