Refcount logging doesn't play nice with _INHERITED addref/release

RESOLVED DUPLICATE of bug 326603

Status

()

RESOLVED DUPLICATE of bug 326603
13 years ago
13 years ago

People

(Reporter: bzbarsky, Assigned: dougt)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

I was debugging a necko leak, and couldn't find nsHttpChannel in the leak output
because that class uses NS_IMPL_ADDREF/RELEASE_INHERITED, so the data that was
logged was actually for the superclass (nsHashPropertyBag in this case).  It
would be nice if we could log the addref/release with the right classname.  The
problem I ran into when I tried this using a size of 0 (so as not to confuse the
actual numbers) is that nothing got logged because of the aInstanceSize > 0
checks in GetBloatEntry() (in nsTraceRefcntImpl.cpp).

So would it be ok to skew the numbers in this case to get better output in the
log?  Or not worth it?  Or can we make both work somehow?
Looks like darin fixed this.

*** This bug has been marked as a duplicate of 326603 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.