contained iframe element doesnt load required webpage

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: rodneyc, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-GB; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Your browser has a problem with the iframe element when employed by more than
one  web page. In this case there are 3 pages accessed fom a home page and all
containing an iframe element,but only the first page's iframe element is able to
access a web page source.

Reproducible: Always

Steps to Reproduce:
1. enter the page from the homepage
2.
3.

Actual Results:  
see details above

Expected Results:  
 loaded a page

Comment 1

13 years ago
The URL given in this bug report does not contain any IFRAMEs.

Reporter: Please provide a URL demonstrating the problem or attach a testcase
to this report.

Comment 2

13 years ago
Reporter answered via e-mail:

> I am developing a site, vidtraining.com, primarily to run on Internet
> Explorer, which at this stage runs fine on that browser.
> I decided also to try and get it to run on Firefox but we have a problem.
> There are 3 pages that can be visited from the home page. These are 'School
> employees', 'Schools', and 'Insurers'.
> Each one of these pages contains an iframe which should programatically
> (javascript) receive a php source which, when visited by the submission of a
> logon, should be actioned.
> Firefox has no problem when dealing with the 'School employees' page, but
> the other 2 pages will not submit the logon.
> I have determined that the reason for this is because the iframe cannot load
> a source page (in fact any page). That's the problem;Why not?

You are inserting the IFRAME into a DIV with style="display:none". Apart from
that this works for me. Note that your HTML is invalid in many ways: INPUT
elements without a FORM, missing quotes around attribute values etc. (but that
does not cause the problem described).

There is a nice HTML validator that might be useful: http://validator.w3.org/

-> marking as WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.