don't check for "Internet" property in "Email" line of vCard

RESOLVED FIXED in Thunderbird1.1

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: J Luh, Assigned: Scott MacGregor)

Tracking

Trunk
Thunderbird1.1

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
Thunderbird requires an "Email" property in a vCard object to contain the
parameter "Internet" indicating an Internet address type:

EMAIL;INTERNET:example@example.com

However, Thunderbird should accept

EMAIL:example@example.com

because INTERNET is the default in vCard 2.1
(http://www.imc.org/pdi/vcard-21.txt). The same is true in vCard 3.0 (RFC 2426).
I will attach a patch that fixes this.

I suppose the really correct thing to do would be to make sure the vCard does
not specify a non-Internet address type (X.400, eWorld, etc.), but that would
probably be overkill--I doubt there are many vCards floating around with eWorld
addresses in them.
(Reporter)

Comment 1

13 years ago
Created attachment 188270 [details] [diff] [review]
simple patch to make vCard parsing more lenient

tested in my Mac OS X build, seems to work
Attachment #188270 - Flags: review?(mscott)
(Reporter)

Comment 2

13 years ago
Created attachment 188272 [details] [diff] [review]
patch to make vCard parsing more lenient

tested in Mac OS X build
Attachment #188270 - Attachment is obsolete: true
Attachment #188272 - Flags: review?(mscott)
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1?
(Reporter)

Updated

13 years ago
Flags: blocking-aviary1.1? → blocking1.8b4?
(Assignee)

Updated

13 years ago
Attachment #188270 - Flags: review?(mscott)
(Assignee)

Comment 3

13 years ago
Comment on attachment 188272 [details] [diff] [review]
patch to make vCard parsing more lenient

this looks pretty straight forward to me. 

My only question is, if internet is the assumed default, are there are other
valid values that we would now be incorrectly assuming as email addresses?

i.e. with this change

email;randomprop:myaddress

would now end up as an address where before we would have skipped it.
Attachment #188272 - Flags: review?(mscott) → review+
(Assignee)

Updated

13 years ago
Attachment #188272 - Flags: superreview?(bienvenu)

Comment 4

13 years ago
Comment on attachment 188272 [details] [diff] [review]
patch to make vCard parsing more lenient

seems OK to me - I agree that eWorld addresses aren't going to be too common. I
think the internet has won :-)
Attachment #188272 - Flags: superreview?(bienvenu) → superreview+
(Reporter)

Comment 5

13 years ago
Comment on attachment 188272 [details] [diff] [review]
patch to make vCard parsing more lenient

re: comment 3 and comment 4, yeah, I think in this case doing fewer checks on
the type is optimal even if one out of every 10,000 times it's the wrong thing
to do.
Attachment #188272 - Flags: approval1.8b4?

Updated

13 years ago
Attachment #188272 - Flags: approval1.8b4? → approval1.8b4+
(Reporter)

Comment 6

13 years ago
Thanks -- mscott or bienvenu, can you please check this patch in and mark the
bug resolved? I don't have checkin privileges. (Patch has r, sr, and approval1.8b4).
(Assignee)

Comment 7

13 years ago
fixed. thanks for the patch. 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Flags: blocking1.8b4?
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird1.1
No longer blocks: 229001
*** Bug 229001 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.