Status

P3
critical
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: v, Assigned: cbegle)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
The site is about the worst I've seen with that yacky, bloated, discusting
dynamic html sh*t, but nevertheless, it should crash.
Reproduced on Linux M14. Confirming.

Here's an odd one. Load this page in NS 4.6 on Linux, do a View Source and then
resize the window. The source window turns into another rendering of the web
page! Freaky... Could be there's something odd with their source...

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

19 years ago
on today's nightly, windows 98, cannot reproduce.  I get a javascript error.
Can the reporter confirm this?
Offtopic: Can't reproduce odd NS View Source behaviour - maybe my copy of NS was 
just stuffed at that point :-)

Add M14 W95 to list of known problem platforms.

Gerv

Updated

19 years ago
Severity: normal → critical
Keywords: crash

Comment 4

19 years ago
Not able to crash with 3/7 bits under NT.  Will try again later today with 3/9
build.
(Assignee)

Comment 5

19 years ago
unable to reproduce with the 2000030913 build on linux, either.  unless someone
can reproduce this with a recent build, and we can figure out what component
this crashed in, there is not a lot we can do about this.

gervase? v@iki.fi?  would one of you try reproducing this again with a recent
nightly build?
(Using Win95) M14 crashes on the home page with:

MOZILLA caused an invalid page fault in
module JS3250.DLL at 014f:60ad9516.
Registers:
EAX=00000000 CS=014f EIP=60ad9516 EFLGS=00010202
EBX=0068edf4 SS=0157 ESP=0068ecbc EBP=0068edd8
ECX=02105b70 DS=0157 ESI=01067c20 FS=12e7
EDX=00000000 ES=0157 EDI=02105cc0 GS=0000
Bytes at CS:EIP:
8b 08 8d 55 cc 52 8d 55 b0 8b 49 04 52 57 50 ff 
Stack dump:
0068eea4 00000000 014b0aa0 817bf17c 00000014 7800136c 78034108 0068ed40 78001417 
00000009 007a0070 00000009 00000003 014b0aa0 00000078 00000018 

However, this crash is not apparent in recent builds. However I can reproducibly 
crash 30000308 by going to http://www.sony.fi and clicking on the Super Audio CD 
link:

MOZILLA caused an invalid page fault in
module <unknown> at 0000:00000001.
Registers:
EAX=00000000 CS=014f EIP=00000001 EFLGS=00250246
EBX=00000000 SS=0157 ESP=0068dec0 EBP=0068defc
ECX=004678f4 DS=0157 ESI=01d2eed0 FS=1127
EDX=10020839 ES=0157 EDI=00000000 GS=1116
Bytes at CS:EIP:
00 00 00 00 04 70 00 16 00 c3 0d 65 04 70 00 65 
Stack dump:
01d28310 01d2eee0 ffffffff 01ca7de0 00061e60 00000000 00000000 01d366e0 01d28e00 
00000000 01d28310 00000001 00000010 01d09c00 01ca7da0 0068e05c 

However, as you can see, this is module <unknown>.

cbegle@netscape.com - your call :-) Can you reproduce _this_ crash?

Gerv

Comment 7

19 years ago
v@iki.fi emailed me saying that s/he could not reproduce with 30313 nightly on 
NT and Linux

Comment 8

19 years ago
Linux build 2000-03-10-13 does not crash when loading this URL. But the
following message appear in the console window:

JavaScript Error: syntax error
URL: http://www.sony.fi/
Line number: 77
Line text: -->


If you visit this page with another browser and don't see a similar error, it
may indicate that the site has not yet been updated to support standards
implemented by the Mozilla browser such as the W3C Document Object Model (DOM). 
Please see http://developer.netsape.com/mozilla/ for more information.
JavaScript Error: TypeError: document.images.cmd1 has no properties
URL: http://www.sony.dk/header_2000.js
Line number: 41

If you visit this page with another browser and don't see a similar error, it
may indicate that the site has not yet been updated to support standards
implemented by the Mozilla browser such as the W3C Document Object Model (DOM). 
Please see http://developer.netsape.com/mozilla/ for more information.
Document http://www.sony.fi/ loaded successfully
Document: Done (4.297 secs)

Comment 9

19 years ago
build 2000031306 - worksforme.

reporter - stills seeing this on a new build?
resolving as worksforme, as reporter does not see this in newer build ( 2000030312).
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 11

19 years ago
marking verified works for me
per test 3-31-00 win95 and reporters comments.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.