Closed Bug 299733 Opened 19 years ago Closed 19 years ago

Mac update creates /Applications/DeerPark.app/DeerPark.app

Categories

(Toolkit :: Application Update, defect)

PowerPC
macOS
defect
Not set
major

Tracking

()

RESOLVED FIXED
mozilla1.8final

People

(Reporter: shaver, Assigned: darin.moz)

References

Details

(Keywords: fixed1.8)

Attachments

(1 file)

I just grabbed the July 4 build and let it update to July 5.  The update process
completed successfully, but when it restarted I was in the July 4 build.

A little investigation showed that it installed the update at
/Applications/DeerPark.app/DeerPark.app, instead of at /Applications/DeerPark.app.
Severity: normal → major
Assignee: nobody → darin
Blocks: 290390
Target Milestone: --- → Firefox1.1
The contents of the Mac MAR file looks like this:

2192    0755    DeerPark.app/Contents/MacOS/firefox
1930    0644    DeerPark.app/Contents/MacOS/components/nsSetDefaultBrowser.js
269     0755    DeerPark.app/Contents/MacOS/defaults/profile/prefs.js
...

This bug is caused by the DeerPark.app in the path.  We need to remove that.
Status: NEW → ASSIGNED
Flags: blocking1.8b3?
Flags: blocking1.8b3? → blocking1.8b3+
Attached patch v1 patchSplinter Review
Attachment #188353 - Flags: superreview?(benjamin)
Attachment #188353 - Flags: review?(mconnor)
Attachment #188353 - Flags: superreview?(benjamin) → superreview+
Attachment #188353 - Flags: review?(mconnor) → review+
Comment on attachment 188353 [details] [diff] [review]
v1 patch

a=chase
Attachment #188353 - Flags: approval-aviary1.1a2+
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Keywords: fixed1.8
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: