.TGA files cause FireFox to crash when opend with FireFox

VERIFIED WORKSFORME

Status

()

Firefox
General
VERIFIED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Kevin Phillips, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Whe selecting Mozilla FireFox as the default application for .tga graphic files,
FireFox crashes.

Reproducible: Always

Steps to Reproduce:
1. Find a graphic file with a .tga extentions
2. Right click and select "open with"
3. Select Firefox as the default application to open the .tga file
4. Crash

Actual Results:  
the browser locks up and crashes, have to ctrl-alt-del to kill the process.

Expected Results:  
Either 1. Displayed the Image in the Browser window. or 2. Return messagebox
that states its not a vaild extention or file.
Could you please upload a .tga file (preferably a small one) that shows this
problem (using the create new attachement)
(Reporter)

Comment 2

13 years ago
Cannot upload tga file, the only one I generate are 1.8 megs, your file utility
only supports 300k.

Comment 3

13 years ago
targas typically compress well, zip the file up and attach the zip.
(Reporter)

Comment 4

13 years ago
Zipped the file is 800k and using rar compression it is 694k.
Are you able to supply a Talkback ID?
(Reporter)

Comment 6

13 years ago
I cannot provide a talkback id as talkback is not installed.

Comment 7

13 years ago
Must be fixed asap
Adding 'qawanted' based on comment #7.
Keywords: qawanted

Comment 9

13 years ago
chris@thecongo.co.uk: why must a bug that has no testcase and no stacktrace and
is not triaged be fixed asap?

reporter: please email a zip'd tga to timeless@gmail.com
(Reporter)

Comment 10

13 years ago
Zipped targa file mailed to timeless@gmail.com as requested

Comment 11

13 years ago
I'm unable to reproduce this with Firefox 1.0.6 or 1.5b2 and Quicktime 6.5.1.

Kevin - do you know what plugin is handling .tga files and it's version?
(Reporter)

Comment 12

13 years ago
I just tried it in 1.07 and the bug seems fixed. Don't know about earlier
version's and it looks like quicktime is handleing the plugin. I know when I
first reported this quicktime would NOT work with FireFox. I totaly forgot about
this until the recent flurry of posts in the last 2 days.

Thanks.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
<- VERI per comment #12
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.