Find functionality doesn't find CSS-generated text

VERIFIED DUPLICATE of bug 12460

Status

()

Toolkit
Find Toolbar
VERIFIED DUPLICATE of bug 12460
13 years ago
10 years ago

People

(Reporter: Graham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I often write programming notes and other documentation using HTML. In my CSS
stylesheet, I have this:

.fixme {
	color: 800000;	
}

.fixme:before {
	content: "FIXME: "
}

Thus if I write <p class="fixme"> or whatever, the browser formats this text
specially, and generates the text "FIXME:" at the beginning of that container.

This morning I noticed that if I hit "Find" and type "FIXME", Firefox doesn't
find the text, even though it's clearly visible on the screen.

Reproducible: Always

Steps to Reproduce:
1. View an HTML document containing CSS-generated text.
2. Open the Find bar, and search for the generated text.

Actual Results:  
"Phrase not found"

Expected Results:  
Should have found the generated text.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 12460 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.