about:logo should display product specific logo on SeaMonkey instead of Mozilla star

VERIFIED FIXED in mozilla1.8beta4

Status

P1
normal
VERIFIED FIXED
13 years ago
7 months ago

People

(Reporter: kairo, Assigned: kairo)

Tracking

Trunk
mozilla1.8beta4

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

13 years ago
See bug 285696 comment 69 - I accidentally changed the about:logo image for
Camino along with SeaMonkey rebranding.

I guess the one you're using comes out of embed.jar, right? So it would be OK if
we would have our logo image in toolkit.jar for SeaMonkey (i.e. if MOZ_SUITE is
set) and else leave in the old Mozilla star image?
(Assignee)

Updated

13 years ago
No longer depends on: 285696

Updated

13 years ago
Flags: camino0.9?
(Assignee)

Comment 1

13 years ago
Created attachment 188532 [details] [diff] [review]
patch v1: include a SeaMonkey logo only #ifdef MOZ_SUITE

OK, I backed out the logo.gif for perf testing today and decided to not revert
the backout again, so at least it looks OK in Camino etc. for now.

Here's an a bit hacked solution for the problem:
This is including the SeaMonkey logo.gif in the xpfe toolkit.jar only #ifdef
MOZ_SUITE, else it's using the normal mozilla star logo.gif

Of course, the new logo.gif has to be checked in at the new location along with
that. I've been discussing the location with Neil today, the one in the patch
is not final yet, but it's easy to change.
It may be reasonable to use suite/base/branding/ instead of suite/app/
Attachment #188532 - Flags: review?(neil.parkwaycc.co.uk)
i think bsmedberg wanted to get camino over to the xre sometime in the near
future, and that would involve pulling in toolkit, iirc.
this really should be a core bug, i guess. moving it over there.
Component: General → Build Config
Flags: review?(neil.parkwaycc.co.uk)
Flags: camino0.9?
Product: Camino → Core
Version: unspecified → Trunk
ok so, shouldn't branding-like things like this really be in chrome://branding/
somewhere?

Comment 5

13 years ago
Yes, this sounds like it really does belong in chrome://branding/content/
(Assignee)

Comment 6

13 years ago
(In reply to comment #4)
> ok so, shouldn't branding-like things like this really be in chrome://branding/
> somewhere?

I believe that ideally, the whole about: and about:logo stuff should be there,
which would make it product-specific and make my hack unnecessary.

Unfortunately, this would need a patch across all products and toolkits, as
about:logo is hardwired to chrome://global/content/logo.gif in the global about
protocal code.

I'm morphing the bug description to the current state of this, as the Mozilla
star is back in and Camino should be fixed, but now SeaMonkey has to swallow the
problem of showing a very wrong about:logo on its about: page.

I believe my patch is still valid as a short-time hack to get it displayed
correctly.

It's a hack though.

Additionally, though I can't mark it, this bug is blocking-seamonkey1.0a+

OS: MacOS X → All
Priority: -- → P1
Hardware: Macintosh → All
Summary: about:logo should not display SeaMonkey logo → about:logo should display product specific logo on SeaMonkey instead of Mozilla star

Comment 7

13 years ago
(In reply to comment #2)
>i think bsmedberg wanted to get camino over to the xre sometime in the near
>future, and that would involve pulling in toolkit, iirc.
Well toolkit doesn't have a logo at all.
(Assignee)

Comment 8

13 years ago
Created attachment 188537 [details] [diff] [review]
patch v2: place an override into suite/ - not touching xpfe/global

OK, here's a patch that looks clear to me, though it still needs to override
toolkit.jar for SeaMonkey.

I'd like to get either the first or second patch in as a short-time fix, and
deal with a long-term fix, involving the about protocol handler, later.
Attachment #188537 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Comment 9

13 years ago
(In reply to comment #7)
> (In reply to comment #2)
> >i think bsmedberg wanted to get camino over to the xre sometime in the near
> >future, and that would involve pulling in toolkit, iirc.
> Well toolkit doesn't have a logo at all.

Just out of interest, how do they deal with about:logo being defined in the list
in
http://lxr.mozilla.org/mozilla/source/netwerk/protocol/about/src/nsAboutRedirector.cpp#60
?

Comment 10

13 years ago
Comment on attachment 188532 [details] [diff] [review]
patch v1: include a SeaMonkey logo only #ifdef MOZ_SUITE

>+        content/global/logo.gif                     (/suite/app/logo.gif) 
r=me with a better path such as that discussed on IRC.
Attachment #188532 - Flags: review+

Updated

13 years ago
Attachment #188532 - Flags: superreview?(jag)
(Assignee)

Comment 11

13 years ago
Comment on attachment 188537 [details] [diff] [review]
patch v2: place an override into suite/ - not touching xpfe/global

In that case, this approach is obsolete.

The path we want to use for the logo now is /suite/chrome/branding/logo.gif (as
discussed on IRC)
Attachment #188537 - Attachment is obsolete: true
Attachment #188537 - Flags: review?(neil.parkwaycc.co.uk)

Comment 12

13 years ago
Comment on attachment 188532 [details] [diff] [review]
patch v1: include a SeaMonkey logo only #ifdef MOZ_SUITE

sr=me, provided the appropriate changes are made before you check in (and
perhaps attach the updated patch here?)
Attachment #188532 - Flags: superreview?(jag) → superreview+
(Assignee)

Comment 13

13 years ago
Comment on attachment 188532 [details] [diff] [review]
patch v1: include a SeaMonkey logo only #ifdef MOZ_SUITE

requesting approval. This is xpfe-specific and only visible in SeaMonkey,
additionally blocking the SeaMonkey alpha.
Attachment #188532 - Flags: approval1.8b3?
(Assignee)

Comment 14

13 years ago
Comment on attachment 188532 [details] [diff] [review]
patch v1: include a SeaMonkey logo only #ifdef MOZ_SUITE

move a? to 1.8b4
Attachment #188532 - Flags: approval1.8b3? → approval1.8b4?

Updated

13 years ago
Attachment #188532 - Flags: approval1.8b4? → approval1.8b4+
(Assignee)

Comment 15

13 years ago
Checking in mozilla/suite/branding/content/logo.gif;
/cvsroot/mozilla/suite/branding/content/logo.gif,v  <--  logo.gif
initial revision: 1.1
done
Checking in mozilla/xpfe/global/jar.mn;
/cvsroot/mozilla/xpfe/global/jar.mn,v  <--  jar.mn
new revision: 1.85; previous revision: 1.84
done

This should be fixed now.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8b3) Gecko/20050714 SeaMonkey/1.0a]
(nightly) (W98SE)

V.Fixed.
Status: RESOLVED → VERIFIED
Target Milestone: --- → mozilla1.8beta4

Updated

12 years ago
Duplicate of this bug: 242423

Updated

7 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.