Firefox creating invalid file entries for cookies file

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: samuella, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

After turning off the machine improperly (by unplugging it or holding down the
power button), and then rebooting, Windows will scan the hard disk by default.
Nearly always my cookies are deleted due to what Windows reports as "invalid
file entry". 

Reproducible: Always

Steps to Reproduce:
1. Improperly turn off computer by either cutting off the power or by turning it
off manually.
2. Turn computer back on.
3. Let Windows scan the hard disk.

Actual Results:  
Windows reported that the Firefox cookies file was invalid, and then the file
was deleted.

Expected Results:  
The software, should have created a cookies file that Windows wouldn't recognize
as faulty.
If you power down the computer while Firefox is writing to the cookies files,
there is no way for it to be able to correctly close the file. This happens for
every program, not just Firefox. There is nothing that can be done in this case.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.