crash when pass undefined as column to getCellText() method

RESOLVED DUPLICATE of bug 293717

Status

()

Core
XUL
--
critical
RESOLVED DUPLICATE of bug 293717
13 years ago
10 years ago

People

(Reporter: surkov, Assigned: janv)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

999 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050530
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050530

tree.view.getCellText(index, undefinded) crashs mozilla

Reproducible: Always
Can you provide a talkback ID or a stacktrace?
(Reporter)

Comment 2

13 years ago
Talkback ID: TB7291868K
Could you give a code example?
hm, talkback has no symbols, only shows the crash is in gklayout

what kind of tree view is this?
(Reporter)

Comment 5

13 years ago
I use content tree. I add treeitems as DOM nodes and then I get their cell text
by getCellText() method.
(Reporter)

Comment 6

13 years ago
Created attachment 188614 [details]
testcase
I don't crash with 2005-07-07-06.

The build you crashed with is old: 2005-05-30-06.  Do you crash with a nightly
build?
(Reporter)

Comment 8

13 years ago
I cannot download latest nightly build. If you can't get a crash with recent
build then mark this bug as invalid or worksforme.
I can get it to crash with a 2005-05-25 trunk build, but with a 2005-07-03
build, I get this js error with the testcase:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsITreeView.getCellText]"  nsresult:
"0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame ::
file:///C:/Documents%20and%20Settings/Martijn/Desktop/1.xul :: get :: line 17" 
data: no]

I've used 
netscape.security.PrivilegeManager.enablePrivilege('UniversalXPConnect
UniversalBrowserRead');
to get the testcase working on my local hard drive.

So I think this is already fixed somehow. I'm marking this WORKSFORME, if
someone can still reproduce with the latest build, then please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
oh, that's why I couldn't find an impl that would crash... because it's fixed
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

*** This bug has been marked as a duplicate of 293717 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: xptoolkit.trees → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.