copying queue.html.tmpl to en/custom/requests causes bad hash ref on "My Requests"

RESOLVED INVALID

Status

()

Bugzilla
Attachments & Requests
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: lfstevens, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Copied the default queue.html.tmpl to custom/request.
Clicked My Requests. Got:

Can't use string ("request/queue.html.tmpl: Permiss") as a HASH ref while
"strict refs" in use at
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Provider.pm line 690

Erased custom/request/queue.html.tmpl. Clicked My Requests. No error.

Copied again. Same problem. Erased again. No problem.

Reproducible: Always

Steps to Reproduce:
1.Copied the default queue.html.tmpl to custom/request.
2.Clicked My Requests. 
Actual Results:  
Can't use string ("request/queue.html.tmpl: Permiss") as a HASH ref while
"strict refs" in use at
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Template/Provider.pm line 690

Expected Results:  
Raised My Requests page.

Comment 1

13 years ago
After having copied queue.html.tmpl in template/en/custom/request/, you have to
run checksetup.pl. The error message you got is because you forgot to do that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.