Closed Bug 299964 Opened 17 years ago Closed 17 years ago

Tabs open in a new window regardless of contrary preference setting

Categories

(Camino Graveyard :: Tabbed Browsing, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 274143

People

(Reporter: nashton, Assigned: mikepinkerton)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050620 Camino/0.9a1
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b2) Gecko/20050620 Camino/0.9a1

I have set all new windows to oppen in a new tab - but regardless, t clicking a
URL results in a new window opening.

Reproducible: Always

Steps to Reproduce:
open a new url by clicking on a linkk
Actual Results:  
a new window opens 

Expected Results:  
open a tab
Appears to work on any link that opens in a new window:
Testcase:
http://2002register.com/viewImages/viewPictures.jsp?pageNum=1
- click on any pictures and watch them open in a new window rather than a tab.
Is this because that page uses target=_blank? In Deer Park they don't open in a
new window (but rather in a new tab), but that's probably because of it's more
advance single window mode prefs.
Yes, this is that. Bug 274143 probably covers this.

In addition, this is a hidden pref as noted on the support page of cb.o.

http://www.caminobrowser.org/support/sup_hiddenprefs.html

Duping...

*** This bug has been marked as a duplicate of 274143 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
(In reply to comment #4)
> In addition, this is a hidden pref as noted on the support page of cb.o.
> 
> http://www.caminobrowser.org/support/sup_hiddenprefs.html#DisableTargetBlank

The pref listed on that page hasn't worked since December.  Use 

user_pref("browser.link.open_newwindow", 1);

to disable target="_blank" in 0.9a1 and above.
You need to log in before you can comment on or make changes to this bug.