format=flowed url wrapping doesn't work with messages from Apple Mail

RESOLVED DUPLICATE of bug 5351

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 5351
13 years ago
13 years ago

People

(Reporter: Alec Flett, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Apple Mail has this annoying tendency to wrap long URLs with format=flowed.

It would be nice if thunderbird could somehow detect that a url has been
wrapped, and re-join it on the other end. Right now if I recieve a url from an
apple mail user, something like:

http://www.domain.com/Some/Very/Long/URL/file.html

it can get wrapped to
http://www.domain.com/Some/Very/Long/URL/
file.html

When this is reassembled using the normal format=flowed rules, these come in as
seperate words:
http://www.domain.com/Some/Very/Long/URL/ file.html

And so only the first part of the url is clickable and you don't get the first url

Perhaps there could be some rule for this, like if the last line of a flowed
line is a url, and ends with "/" then append the next word without a space?

Comment 1

13 years ago
This appears to be the same as bug 253284 -- the "format=flowed" aspect doesn't 
really seem to be pertinent, except that Apple Mail is prone to breaking URLs 
when f=f is turned on.  (And not when it's turned off?)

Comment 2

13 years ago
No response from reporter, duping.

*** This bug has been marked as a duplicate of 5351 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.