Closed Bug 299983 Opened 15 years ago Closed 15 years ago

Link open behaviour: "Open links meant to open a new window" in "a new tab in the current window" no longer works

Categories

(SeaMonkey :: UI Design, defect, major)

x86
All
defect
Not set
major

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: tobias, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050707 SeaMonkey/1.0a Mnenhy/0.7.2.10005
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b2) Gecko/20050707 SeaMonkey/1.0a Mnenhy/0.7.2.10005

In currrent Trunk-Nightly 2005070706 the Tebbed Browsing Pref "Link open
behaviour: Open Links meant to open a new window in A new tab in the current
window" and same at "Links from other applications..." faild. 

The Links will open a new Browser-Window. Possibly this was an regression from
Checkin for Bug 299901. 



Reproducible: Always

Steps to Reproduce:
1. Set "Link open behaviour:" to: "A new tab in the current window"
2. Open Link which should open a new window, example: choose the digitimes-Link
 from: http://www.heise.de/newsticker/meldung/61484
3. 

Actual Results:  
Link will be opend in a new window

Expected Results:  
Link should be opend in a new tab in current window

JS-Console throws: 
Error: nsCI is not defined
Source File: chrome://navigator/content/navigator.js
Line: 441

    var isExternal = (aContext == nsCI.nsIBrowserDOMWindow.OPEN_EXTERNAL);
Blocks: 299901
Keywords: regression
This is Seamonkey only.
Assignee: nobody → guifeatures
Component: Tabbed Browser → XP Apps: GUI Features
Product: Core → Mozilla Application Suite
QA Contact: tabbed-browser
Summary: Link open behaviour: Open links open a new window in a new tab faild (regresion) → Link open behaviour: "Open links meant to open a new window" in "a new tab in the current window" no longer works

*** This bug has been marked as a duplicate of 299444 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
not a dupe.
bug 299444 is for opening URLs from other applications and is older.  this is a
regression from bug 299901
Severity: normal → major
Status: RESOLVED → REOPENED
Flags: blocking-seamonkey1.0a?
OS: Windows 2000 → All
Resolution: DUPLICATE → ---
Flags: blocking-seamonkey1.0a? → blocking-seamonkey1.0a+
I can confirm this

Mozilla/5.0 (Windows; U; Windows NT 5.0; de-AT; rv:1.8b3) Gecko/20050709
SeaMonkey/1.0a
*** Bug 300485 has been marked as a duplicate of this bug. ***
Blocks: 121969
hmm.  This is now worksforme on linux.  Maybe I fixed both of these (at least
for me) in bug 299444 after all.

Tobias: are you still seeing this?
(In reply to comment #6)
> hmm.  This is now worksforme on linux.  Maybe I fixed both of these (at least
> for me) in bug 299444 after all.
> 
> Tobias: are you still seeing this?

Hmm, no, it was working for me too now using 2005071119. Sorry for my delay, i
have trouble at work at moment and will be away for holidays from 07-15 to
07-30, so I am very short on testing. :(

I would like to mark this as resolved=worksforme while I think this was fixed
with your patch for Bug 299444. 
Feel free to reopen or file a new one when this issue occours again. 
Status: REOPENED → RESOLVED
Closed: 15 years ago15 years ago
Resolution: --- → WORKSFORME
verified wfm
Status: RESOLVED → VERIFIED
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.