redo spell-as-you-type when language is chnaged

RESOLVED DUPLICATE of bug 305020

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 305020
13 years ago
13 years ago

People

(Reporter: Jo Hermans, Assigned: Scott MacGregor)

Tracking

(Blocks: 1 bug)

unspecified
Dependency tree / graph
Bug Flags:
blocking-aviary1.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
Thunderbird version 1.0+ (20050626)

When you use the spell-check dialog, and you change the language, you have the
option to recheck the entire page. this is handy is you keep switching between
differetn languages, and you started to type a message in a different language
than the default (the spell checker suddenly started to complain about almost
every word).

But when you use spell-as-you-type, and you notice that almost every word is
flagged as incorrect, you can change the language in the Options or the
Spell-Check dialog. But when you changed the language, the page isn't rechecked,
and you notice that the words stay flagged as incorrect.

For example (assuming that you have installed English and Dutch dictionaries):
- switch on spell-as-you-type
- set the language to English
- type "dit is een test" (Dutch for "this is a test")
- notice that 3 words out of 4 are incorrect
- open the spell-check dialog and change the language to Dutch
- notice that the words stay flagged

Work around :
- switch off spell-as-you-type
- switch it back on

See also bug 69687.
(Reporter)

Comment 1

13 years ago
The solution would be quite easy, just call InlineSpellChecker.checkDocument
again when the language is checked :

function RefreshInlineSpellChecker(target)
{
   if (InlineSpellChecker.inlineSpellChecker)
   {
     if (InlineSpellChecker.inlineSpellChecker.enableRealTimeSpell)
       InlineSpellChecker.checkDocument(window.content.document);
   }
}

(similar to ToggleInlineSpellChecker in
mail/components/compose/content/MsgComposeCommands.js)

Updated

13 years ago
Flags: blocking-aviary1.1?
(Reporter)

Updated

13 years ago
Blocks: 300896

Updated

13 years ago
Flags: blocking-aviary1.5? → blocking-aviary1.5-
(Reporter)

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 305020 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.