multiple/continuous password prompts when the password is invalid

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
14 years ago
11 years ago

People

(Reporter: alexeys, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 2008-04-30)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050708 Firefox/1.0+
Build Identifier: version 1.0+ (20050708) Windows

sometimes opens multiple login dialogs, sometimes the dialogs have to be
cancelled one by one, often asks for login again even though the previous login
was successful. 

Reproducible: Always

Steps to Reproduce:
1. configure Thunderbird to talk to an IMAP server via IMAP proxy (for example
SpamPal); set a minimal update interval (1 minute?);
2. open a folder
3. make server inaccessible (disconnect the cord);
4. login failed dialog should appear;
5. try to login,it should fail;
6. wait a little;
7. connect the cord back;
8. login again
Actual Results:  
you will be prompted again to login

Expected Results:  
the last result should be final - if either if Cancel is pressed or the last
login was successful - no more login requests should be open.

It looks like Thunderbird wants to separately report an error and ask to login
for every connection it makes, but sometimes I have to cancel more then 5 login
dialogs.
maybe, this is dup of bug 219162.

*** This bug has been marked as a duplicate of 219162 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
Bug 219162 has been fixed in Mozilla 1.5 final.
So this is (dup of) another bug?

Updated

13 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 160425 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 4

13 years ago
I just got my account locked out because Thinderbird tried to login 5 times in a row with my old password. As if once failed login is not enough.
Severity: normal → major
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Summary: multiple/continuous password prompts when using IMAP proxy (like SpamPal) and IMAP server is down. → multiple/continuous password prompts when the password is invalid
(Reporter)

Comment 5

13 years ago
This maybe a duplicate of bug 249240 .
(Reporter)

Comment 6

12 years ago
?!?! I just got my account locked out again, because Thunderbird decided to try to login with my old password 4 times in a row. When is it going to be fixed. Corporate users usually have password renewal policy. It is a nightmare every time the password should be changed.

Comment 7

12 years ago
Hope the following helps:
1. please always supply your release of software from help|about
2. do any of these open bugs match your issue http://tinyurl.com/rfhqa
3. when you comment next, an imap protocol log will be helpful
 - instructions here and put "imap" in for <protocol>  http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap
 - upload (attach) the log as a FILE to this bug
Component: General → Mail Window Front End
QA Contact: front-end
Alexey, could you please check the issue still occurs in the latest supported Thunderbird 2.0.0.x or trunk nightlies?
Whiteboard: CLOSEME 2008-04-30
No additional information since last comment -> resolving incomplete.

Please comment if the issue still occurs with the latest supported 2.0.0.x or trunk nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.