visual errors with close button when a lot of tabs are opened.

RESOLVED DUPLICATE of bug 221684

Status

()

Firefox
Tabbed Browser
--
trivial
RESOLVED DUPLICATE of bug 221684
13 years ago
13 years ago

People

(Reporter: Alejandro Torras, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I opened a lot of tabs from "open in tabs" option of freshmeat.net RSS bookmark.

The error are:
1) The close button is back the last visible tab (still visible thanks to
transparency of the tab)
2) The visibility of that last tab and the close button behaves wrongly when
moving the cursor around there: sometimes the close tab is above (at least it's
displayed above the tab) sometimes the tab goes to top.
3) The other tabs disappeared

I think that these problems could be fixed if the close button is always on top
of the tab pane or to be displayed the last.

I think that the final fix to all these problems could be make an scrolled tab
pane to put all the tabs.

By example:

+------------------------------------------------------------+
| Nowadays Tab pane                                          |
| +-----------------------------------------------+ +------+ |
| | Scrolled Tab pane                             | |   CB | |
| +-----------------------------------------------+ +------+ |
+------------------------------------------------------------+

CB stands for close button.

I hope this could help you :)

Regards!

Reproducible: Always

Steps to Reproduce:
1. Open a lot of tabs
2. Optionally, move the cursor around the close button

Actual Results:  
wrong display & "onmouseover" behaviour of close button and last tab.

Expected Results:  
The tab pane should be scrollable or, at least, the last tab should not be
displayed in the same place of the close button.
(Reporter)

Comment 1

13 years ago
Created attachment 188719 [details]
One screenshoot
(Reporter)

Comment 2

13 years ago
Created attachment 188720 [details]
Another screenshoot
(Reporter)

Comment 3

13 years ago
Created attachment 188723 [details]
The last one

*** This bug has been marked as a duplicate of 221684 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.