Closed Bug 300154 Opened 15 years ago Closed 15 years ago

minimum required version of DBD::Pg (1.31) fails to detect PostgreSQL version for PostgreSQL 8

Categories

(Bugzilla :: Installation & Upgrading, defect)

2.20
defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: rl03, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050526 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050526 Firefox/1.0.4

$ wget http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.20rc1.tar.gz
$ tar xjvf ... && cd ..
$ ./checksetup.pl
$ <edit localconfig, setting $db_driver to pg, etc.
$ ./checksetup.pl
<snip>
Checking for      PostgreSQL (v7.03.0000) 
Your PostgreSQL v00.00.0000 is too old.
   Bugzilla requires version 7.03.0000 or later of PostgreSQL.
   Please download and install a newer version.

$ psql -V
psql (PostgreSQL) 8.0.1
contains support for command-line editing

Reproducible: Always
Version: unspecified → 2.20
I'm fairly certain that this is a bug in DBD::Pg, and not in Bugzilla. I've had
another user report it, who discovered that it was a DBD::Pg bug. I'd suggest
upgrading DBD::Pg, and then if that doesn't work, contacting the authors of
DBD::Pg for a fix.
Summary: checksetup.pl fails to detect PostgreSQL version → checksetup.pl fails to detect PostgreSQL version for PostgreSQL 8
upgrading to most recent version (DBD-Pg-1.43) detects Postgres 8 correctly.
Please update checksetup.pl and the relevant documentation.
Summary: checksetup.pl fails to detect PostgreSQL version for PostgreSQL 8 → minimum required version of DBD::Pg (1.31) fails to detect PostgreSQL version for PostgreSQL 8
Well, we don't officially support Pg 8 yet, but I'll probably make a release
note, or somehow modify checksetup to deal with this.
Keywords: relnote
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
The doc part is covered by bug 297475.
Blocks: meta-pg
mkanat, I suggest to close this bug as bug 297475 already mentions that DBD::Pg 1.41 is required for Pg 8.
Agreed. WONTFIX in favor of a documentation note, both in the relnotes and in the docs themselves. (It's not noted in checksetup, though.)
Status: NEW → RESOLVED
Closed: 15 years ago
Keywords: relnote
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.