TBird ignores Privacy Preference to Block loading images when forwarding

VERIFIED DUPLICATE of bug 263345

Status

VERIFIED DUPLICATE of bug 263345
13 years ago
13 years ago

People

(Reporter: drrubenh, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/412 (KHTML, like Gecko) Safari/412
Build Identifier: 1.0.2

When forwarding a message with remote images (mostly when reporting the message as spam), the 
images are loaded into the forwarded email even though the Privacy preference to "Block loading of 
remote images in mail messages" is checked.

Reproducible: Always

Steps to Reproduce:
1. Make sure the "Block loading of remote images in mail messages" preference is checked.  It is under 
the Privacy section, under the Advanced section of preferences.
2. Get a spam with remote images.  Notice that the images are not in the email.  Good T-Bird.
3. Forward the message to someone, preferably the spam blocker email address provided by your ISP.
4. Notice that the images have been loaded into the forward email.  Bad T-Bird.

Actual Results:  
T-Bird loaded the images it was not supposed to.

Expected Results:  
Step 4 should have had a forwarded email that looked exactly like the email in the Inbox, without the 
loaded images.  Spammers use these remote images to verify valid email addresses.

As a software engineer, I believe this should be a super easy fix.  The code for the generation of forwarded 
messages should check the flag for blocking images, just like the Inbox code does.

Comment 1

13 years ago
Duplicate of/related to Core bug 263345?

Comment 2

13 years ago
Also seen in TB 1.0 (20041206) on Windows.

Comment 3

13 years ago
*** Bug 300426 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 263345 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.