Gratuitous transparency of certain document elements when browser.display.use_document_colors is false.

VERIFIED DUPLICATE of bug 255411

Status

()

VERIFIED DUPLICATE of bug 255411
14 years ago
14 years ago

People

(Reporter: dhilvert, Unassigned)

Tracking

1.0 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.8) Gecko/20050610 Firefox/1.0.4 (Debian package 1.0.4-3)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.7.8) Gecko/20050610 Firefox/1.0.4 (Debian package 1.0.4-3)

Certain document elements, including drop-down menus, tooltips, and even static
text, are incorrectly given transparent backgrounds when
browser.display.use_document_colors is false, although they display correctly
when browser.display.use_document_colors is true.  For example, the menu object
at the top of the page at the provided URL has an incorrectly transparent
background when use_document_colors is set to false.  This can be observed by
scrolling down the page, or by passing the pointer over the menu headers.  This
problem is pervasive, and affects menus, tooltips, and even non-dynamic text
layout.  A particularly egregious example can be seen at
http://www.popjisyo.com/ -- this is a pop-up dictionary tool, wherein the pop-up
text is almost invariably unreadable when use_document_colors is false.

Reproducible: Always

Steps to Reproduce:
1.  In about:config, set browser.display.use_document_colors to false
2.  Load a page containing dynamic drop-down menus, tooltips, or certain other
elements.
3.  Note incorrectly transparent backgrounds on drop-down menus, tooltips, etc.

Actual Results:  
Background is incorrectly transparent.  E.g., underlying text from other
document elements can be seen through the incorrectly-rendered element.

Expected Results:  
The background should be opaque.

Comment 1

14 years ago
I tried this.

UNCONFIRMED -> NEW
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

14 years ago
Assignee: nobody → general
Component: General → GFX
OS: Linux → All
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.0 Branch

Updated

14 years ago
Assignee: general → nobody
Component: GFX → Layout
QA Contact: ian → layout

Comment 2

14 years ago
dupe of '"Use my colors" preference makes popup/hover frames have transparent
background'

*** This bug has been marked as a duplicate of 255411 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
v. dupe
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.