Accept external entities in xml documents.

RESOLVED DUPLICATE of bug 69799

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 69799
13 years ago
13 years ago

People

(Reporter: Yoric, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 Firefox/1.0.4

The XML parser/interpreter currently used in Mozilla rejects XML documents when
they rely on entities defined in external DTDs, unless the scheme is chrome or
the dtd has been installed in some magic directory, usually not writable by the
user.

This limitation becomes problematic when one has to load files which rely on the
interpretation of external entities (à la XUL, or norms such as OEBPS 1.2). I
believe it is also problematic for authors who attempt to provide
internationalization for remote XUL applications.

Suggestion: alter function IsLoadableDTD() of
http://lxr.mozilla.org/seamonkey/source/parser/htmlparser/src/nsExpatDriver.cpp
(I believe this function is the only culprit)

Before attempting to load from the read-only directory <mozilla bin>/res/dtd,
attempt to load from the user-writable directory <user's profile>/res/dtd. This
will allow extensions to download DTDs if necessary.

Reproducible: Always

*** This bug has been marked as a duplicate of 69799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.