Firefox freezes when visiting crca.co.uk

RESOLVED DUPLICATE of bug 335256

Status

()

--
critical
RESOLVED DUPLICATE of bug 335256
13 years ago
11 years ago

People

(Reporter: bugs, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050602 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050602 Firefox/1.0.4

Firefox uses 98% CPU on both Windows 2000 and on Linux when visiting crca.co.uk.
The page is a frameset. The individual frames do not cause the problem when
loaded on their own. When the frameset is loaded, all the side frames and most
of the main frame loads before the freeze. However, if the individual frames are
visited first (so they are in cache), then the main page is visited, the page
freezes firefox immediately.

Reproducible: Always

Steps to Reproduce:
1. Visit crca.co.uk

Actual Results:  
Firefox UI becomes unresponsive after loading all side frames and most of the
main frame. top (Linux) and task manager (Windows) show around 98% CPU usage for
Firefox

Expected Results:  
Shown the site as normal.

Occurs with default theme and without plugins installed (tested on Windows
computer) and with Qute theme with several plugins installed (Linux computer).
Two different hardware configurations.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050711
Firefox/1.0+ ID:2005071106

Visiting the URL causes firefox to become very unresponsive so this problem is
still present in trunk builds.
It's because of this function:
function monitorScroll(){
which calls setInterval(monitorScroll,0);


*** This bug has been marked as a duplicate of 261633 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 335256
You need to log in before you can comment on or make changes to this bug.