Closed Bug 3004 Opened 22 years ago Closed 13 years ago

Remove debug robot from build

Categories

(Core :: DOM: HTML Parser, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla1.9beta5

People

(Reporter: michael.j.lowe, Assigned: timeless)

References

Details

Attachments

(1 file, 1 obsolete file)

Here is a patch to clean up the debug robot somewhat, and get it working again
in the viewer test program:

http://www.geocities.com:80/SiliconValley/Haven/8120/robot.txt

It is not yet completely working in the viewer, but this patch gets it a long
way there.
Status: NEW → ASSIGNED
QA Contact: 3847
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
Target Milestone: M6
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → REMIND
Target Milestone: M6 → M10
Status: RESOLVED → VERIFIED
Verified REMIND
Keywords: patch
REMIND is deprecated.
Status: VERIFIED → REOPENED
Resolution: REMIND → ---
->harishd (do we still care about the debug robot?)
Assignee: rickg → harishd
Status: REOPENED → NEW
QA Contact: janc → moied
Target Milestone: M10 → ---
Choess: I've never used it and probably will never be used. IMO, we can remove
that file. FUTURING the bug for now.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
bz, since you've been interested in parser lately, do you think you could just
tear out the robot directory entirely? It evidently hasn't been used or missed
for years.
OS: Windows NT → All
Hardware: PC → All
Summary: [PATCH] Debug robot → Remove debug robot from build
What does it do?  Could it be useful for the layout debugger to get it working?
It seems to have been something hooked up in the Viewer app to automatically
parse a collection of HTML documents. It looks like it was intended to pass a
stream listener to the parser which would presumably collect debug information
emitted by the parser, but the comments suggest it was never hooked up.
The debug robot doesn't work anymore (it was apparently written before the
parser could parse a real stream), its content sink doesn't QI to all of the
right things, and it's just generally a mess. I'll rip it out.
Assignee: harishd → mrbkap
Status: ASSIGNED → NEW
Attached patch diff -N of the removal (obsolete) — Splinter Review
This is a diff -N of the removal. The only real interesting change here is the
makefile change (first file in the diff).
Attachment #189791 - Flags: superreview?(brendan)
Attachment #189791 - Flags: review?(bzbarsky)
Attachment #189791 - Flags: review?(bzbarsky) → review+
Comment on attachment 189791 [details] [diff] [review]
diff -N of the removal

viewer depends on the debug robot, we should move it there instead of removing
it.
Attachment #189791 - Attachment is obsolete: true
Attachment #189791 - Flags: superreview?(brendan)
Blocks: 419858
So let's get this patch updated and remove this :-)
let's just remove it from the build. (cvs removing the files can be done to files that aren't part of a build at any time)
Assignee: mrbkap → timeless
Status: NEW → ASSIGNED
Attachment #306238 - Flags: review?(mrbkap)
Comment on attachment 306238 [details] [diff] [review]
remove it from the build

I'm all for this, do we need to remove viewer (comment 11) at the same time?
Attachment #306238 - Flags: review?(mrbkap) → review+
Viewer was removed in bug 121881, slightly over two years ago.
Comment on attachment 306238 [details] [diff] [review]
remove it from the build

Just throwing this out there: robot isn't used by anything anymore.

This patch doesn't include the removal of the robot directory and the files/dirs in it, see comment 14 for that.
Attachment #306238 - Flags: superreview+
Attachment #306238 - Flags: approval1.9?
Comment on attachment 306238 [details] [diff] [review]
remove it from the build

a1.9+=damons
Attachment #306238 - Flags: approval1.9? → approval1.9+
Comment on attachment 306238 [details] [diff] [review]
remove it from the build

mozilla/parser/htmlparser/Makefile.in 	1.14
Status: ASSIGNED → RESOLVED
Closed: 22 years ago13 years ago
Resolution: --- → FIXED
(In reply to comment #17)
> This patch doesn't include the removal of the robot directory and the
> files/dirs in it, see comment 14 for that.

These were later removed by
{{
2008-03-16 13:30	timeless%mozdev.org 	...  	Bug 3004 Remove debug robot from build
removed robot from the build, this removes it from cvs
NPOB
toolkit changes r=luser, a=luser
}}
Target Milestone: Future → mozilla1.9beta5
You need to log in before you can comment on or make changes to this bug.