Cannot put accents into XHTML (application/xhtml+xml)

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: David Betz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050711 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050711 Firefox/1.0+

The test harness at the below Url demonstrates this.

You wil notice that the second two boxes are blank.

These boxes are...
box3Obj.appendChild(document.createTextNode('Rèsumè'));
box4Obj.appendChild(document.createTextNode('R#232;sum#232;'));

http://davidbetz.net/FirefoxBugs/accents/?xhtml=1

If you were to use the alternate testharness at
http://davidbetz.net/FirefoxBugs/accents/ (which gives text/html), you will see
that everything is working fine.

Reproducible: Always

Steps to Reproduce:
1. http://davidbetz.net/FirefoxBugs/accents/?xhtml=1
2. Look
3.

Actual Results:  
Blank boxes

Expected Results:  
Rèsumè in the boxes

The seriousness of this is that none of our XHTML applications can work with
proper spelling of certain words.  Not the most serious of issues by any means,
but it does prevent us from meeting our requirements.
(Reporter)

Comment 1

13 years ago
This was with the July 11 Nightly build (Deer Park Alpha 2) as well as Firefox
1.0.4.  I've never seen a version that works properly.

Comment 2

13 years ago
How about removing the comment you have wrapped around the js code...

Comment 3

13 years ago
This should indeed be marked invalid, since comments do matter in XHTML/XML,
also in script tags. That's what <![CDATA[ ]]> is for.

To create a workaround for HTML4 browsers, visit:

http://hixie.ch/advocacy/xhtml

Comment 4

13 years ago
Marking invalid INVALID as per comment 2 and comment 3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.