Feature request: "Go up one level in a site"

RESOLVED WONTFIX

Status

()

Firefox
Keyboard Navigation
RESOLVED WONTFIX
13 years ago
12 years ago

People

(Reporter: Volkmar W. Pogatzki, Unassigned)

Tracking

unspecified
x86
All
Points:
---
Bug Flags:
blocking-firefox2 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
"Go up one level in a site" is a vital keyboard navigation function expected to
occur when pressing Alt + Up arrow. 
It should be part of Firefox itself instead of being an extension only. Not
having this functionality in Firefox could be a good reason for using other
browsers like Konqueror instead.

Comment 1

13 years ago
What does going up one level mean? 
Stripping the URL till the last "/" (or if the URL end with a "/" take the slash
before the last)? That has no official meaning in most sites and does definitely
result in 404s or strange relocations in some. Most "levels in a site" as users
experience them are not mapped directly to directories in the URL. I feel this
in the right place as an extension-feature only.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> What does going up one level mean? 
> Stripping the URL till the last "/" (or if the URL end with a "/"  
> take the slash before the last)? 

Exactly that's the point.

> That has no official meaning in most sites and does definitely
> result in 404s or strange relocations in some. 

An awfully bad website design unfortunately is very common to many websites.
Nevertheless Firefox needs to have the basical navigation functions.
Flags: blocking-aviary1.1?

Comment 3

13 years ago
This used to be part of the Site Navigation Toolbar, but that was taken out.

*** This bug has been marked as a duplicate of 187488 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Flags: blocking-aviary1.1?

Comment 4

13 years ago
This is not a dupe of bug 187488. The site navigation bar is for sites that 
have been designed with it in mind. The 'Up' button requested here is like that 
found in Konqueror. There is extension* for this function for Firefox so this 
bug may well be a wontfix on those grounds but it isn't a dupe. 
 
* http://clav.mozdev.org/#goup 
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

13 years ago
Related to Suite bug 33684 and Suite bug 89005?
(Reporter)

Comment 6

13 years ago
(In reply to comment #5)
> Related to Suite bug 33684 and Suite bug 89005?

Not related to bug 89005 but to bug 33684.

*** This bug has been marked as a duplicate of 33684 ***
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

12 years ago
(In reply to comment #7)
> 
> *** This bug has been marked as a duplicate of 33684 ***
> 

Re-opening since 33684 seems to be specifically for seamonkey, not Firefox.

And requesting "blocking‑firefox2" as such most important navigation function should be a function of Firefox itself and not left to an extension.
Status: RESOLVED → REOPENED
Flags: blocking-firefox2?
Resolution: DUPLICATE → ---
This isn't that important.  There's the odd time I'd like this, but considering the number of sites that break/react unpredictably when I manually strip the URL to try this, I don't think its something that should be in the core.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Flags: blocking-firefox2? → blocking-firefox2-
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.