If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Control+W closes TAB also when editing text

RESOLVED DUPLICATE of bug 260188

Status

()

Firefox
Keyboard Navigation
--
enhancement
RESOLVED DUPLICATE of bug 260188
12 years ago
12 years ago

People

(Reporter: Carsten Otto, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050517 Firefox/1.0.4 (Debian package 1.0.4-2)

Hello!

Whenever you press Control+W the current tab closes - just as the documentation
says.
This only is problematic, when you are used to "Control+W deletes the last word"
and have to edit a huge text (for example this bug report) inside Firefox.
Whenever I do a major typo and am not careful enough, the whole tab including
the text disappears. That sometimes means the work of several minutes.
_Please_ make some rule, that inside text fields (or even the address bar and
other fields?) Control+W does delete the last word and not close the tab. A
confirmation dialog "This will close the tab, not delete a word!" would be OK, too.

Thanks a lot,
Carsten Otto

Reproducible: Always

Steps to Reproduce:
1. Write something in my guestbook or any other form field for several minutes.
2. Press Control+W
3. Despair!

Actual Results:  
Tab closes.

Expected Results:  
Word deleted, tab not closed OR warning message displayed.
(Reporter)

Comment 1

12 years ago
Putting following line into .gtkrc-2.0 solves the problem - that's good enough
for me.

# cat ~/.gtkrc-2.0
gtk-key-theme-name = "Emacs"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 260188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.