saved search folder name is bold without unread messages

RESOLVED FIXED in Thunderbird 3

Status

--
minor
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug)

unspecified
Thunderbird 3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: TB version 1.0+ (20050601)

Saved search folder does not "un-bold" when a message is marked as read. 
Clicking on the saved search folder, and then clicking back on the Inbox
resolves it.

Reproducible: Always

Steps to Reproduce:
1. Receive email
2. Mark email as read (or read the email)

Actual Results:  
Saved search folder that includes the email stays "bold"

Expected Results:  
Saved search folder should go back to "normal"

Comment 1

13 years ago
For me this is not always reproducible. I haven't been able to find out when
this happens, it happens rarely, but it does sometimes.

version 1.0+ (20050828)

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
*** Bug 330570 has been marked as a duplicate of this bug. ***

Comment 3

13 years ago
Is the search folder searching over IMAP or local/POP mail?

Comment 4

12 years ago
*** Bug 346333 has been marked as a duplicate of this bug. ***

Comment 5

12 years ago
Still seeing this problem?  I'm unable to reproduce with 2a1-0909/X11, Debian.
(Reporter)

Comment 6

12 years ago
Still happening with TB version 1.5.0.7 (20060909) on Windows

Comment 7

12 years ago
(In reply to comment #5)
> Still seeing this problem?  I'm unable to reproduce with 2a1-0909/X11, Debian.

My tests this morning indicates it works now on Debian with latest Thunderbird (1.5.0.7). However, Matthias says it's still not working for him. I haven't made extensive tests myself.
Cheers! :-)
(Assignee)

Comment 8

12 years ago
I still see this sometimes...still working on how to reproduce it.
Assignee: mscott → bienvenu
QA Contact: front-end

Comment 9

11 years ago
Mattias, still see this?

WFM version 3.0a1pre (2007110302)
(Reporter)

Comment 10

11 years ago
I have noticed that it is still out of sync sometimes, but it's more subtle than it used to be.

Now, to reproduce:
1. Create a saved search for emails tagged as "to do"
2. Mark any email as "to do" (press 4) and then as unread (press M).  Notice that the saved search folder says "(1)" for one unread message.
3. Unmark that email from "to do" (press 4) and then as read (press M).  Notice that the saved search folder still says "(1)"
(Reporter)

Comment 11

11 years ago
Version 2.0.0.6 (20070728)

Comment 12

11 years ago
I even see unread message counts for the search folder, not just the bold text.

Updated

10 years ago
Blocks: 438257
(Assignee)

Comment 13

10 years ago
Created attachment 330927 [details] [diff] [review]
fix for case of deleting new unread message

this is a fix for the reproducible case that I encounter frequently, which is:

1. Create a saved search over unread messages in one or more folders.
2. Send yourself mail that will get added to the saved search.
3. Delete the message w/o reading it (e.g., using the context menu) from the real folder, or, iirc, the saved search.

The saved search will still think it has a new message.
Attachment #330927 - Flags: superreview?(neil)
Attachment #330927 - Flags: review?(neil)

Comment 14

10 years ago
Comment on attachment 330927 [details] [diff] [review]
fix for case of deleting new unread message

>+  PRBool hdrWasNew = m_newSet.BinaryIndexOf(key) != -1;
>   m_newSet.RemoveElement(key);
RemoveElement does actually tell you whether the element existed in the array:
PRBool hdrWasNew = m_newSet.RemoveElement(key);
but RemoveElement calls IndexOf so you might want to do something like this:
PRInt32 newSetPos = m_newSet.BinaryInndexOf(key);
if (newSetPos != -1)
  m_newSet.RemoveElementAt(newSetPos);
...
if (newSetPos != -1)
  flags |= MSG_FLAG_NEW;
Attachment #330927 - Flags: superreview?(neil)
Attachment #330927 - Flags: superreview+
Attachment #330927 - Flags: review?(neil)
Attachment #330927 - Flags: review+
(Assignee)

Comment 15

10 years ago
Nice, I'll do that.
(Assignee)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Thunderbird 3
You need to log in before you can comment on or make changes to this bug.