"overflow: auto" places element on consecutive page instead of splitting it

RESOLVED WORKSFORME
(Needinfo from 2 people)

Status

()

Core
Printing: Output
RESOLVED WORKSFORME
13 years ago
4 years ago

People

(Reporter: David A. Cobb, Unassigned, NeedInfo)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+

I've looked at the source for this page.  My only conclusion is the author got
too clever by half.  There is a wealth of JavaScript here that I can't sort out.

The page is layed out by a table.  It looks fine on the screen.
In PrintPreview, the entire left side of page 1 is covered by a grey box, the
inner content of the page is on page 2.

On paper, page 1 contains all the "outer" frame material -- colorful headers,
navagation buttons, search and feedback boxes from right hand area; the inner
content is again on page 2.

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 189110 [details]
Screenshot of PrintPreview
(Reporter)

Comment 2

13 years ago
Created attachment 189111 [details]
Screenshot of page as rendered in browser (print should look like this)

Comment 3

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
ID:2005071214

Confirming. This looks like it might be related to bug 269111, although I tried
a testcase with `overflow: hidden' in it, and I didn't see this. 
Created attachment 189369 [details]
not minimized testcase

This should be minimized further.

Updated

13 years ago
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Keywords: helpwanted, qawanted

Comment 5

12 years ago
Created attachment 223100 [details]
minimized testcase

Creates described result for
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a2) Gecko/20060523 BonEcho/2.0a2
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060523 Minefield/3.0a1
Attachment #189369 - Attachment is obsolete: true

Comment 6

12 years ago
Bug 165705 describes opposite problem (closely related?).

The grey box doesn't appear anymore for print preview, but printing splits over several pages (see testcase). The box would be a dupe of bug 296111, but the real problem is the printing itself --> hence not duping.

An appropriate behaviour of the "overflow: auto" setting needs to be discussed to decide further measures or resolution of this bug!
Status: UNCONFIRMED → NEW
Component: Layout → Printing
Ever confirmed: true
Keywords: helpwanted
OS: Linux → All
Summary: Printing splits to new page improperly → "overflow: auto" places element on consecutive page instead of splitting it

Updated

12 years ago
Keywords: testcase
QA Contact: layout → printing

Comment 7

4 years ago
WFM on:
Mozilla/5.0 (X11; Linux i686; rv:28.0) Gecko/20100101 Firefox/28.0

Can anyone still reproduce this issue?
Flags: needinfo?(superbiskit)
Keywords: qawanted

Updated

4 years ago
Flags: needinfo?(cignangulo)

Updated

4 years ago
Flags: needinfo?(ispiked)
Yes, this is wfm for me too. Let's mark it wfm.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 9

4 years ago
Per needinfo-flag: WFM on release build
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0
Flags: needinfo?(cignangulo)
You need to log in before you can comment on or make changes to this bug.