Bookmark toolbar menus don't open to file dragged links

RESOLVED DUPLICATE of bug 299185

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 299185
13 years ago
13 years ago

People

(Reporter: John Whitley, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+

The bookmark toolbar folder menus don't open for dragged links on Mac OS X. 
I.e. one can drop a link (from the location bar, web page, etc.) onto the closed
folder and have it appear at the bottom of the menu.  However, the folder menu
won't open to allow filing the link in a particular order, in a submenu, etc. 
For comparison, drag-to-organize works fine on the Windows XP bookmark toolbar.

This is further aggravated as the bookmark toolbar menu doesn't even give
highlight feeback to show where a dragged link will be deposited (in a folder,
on the toolbar itself, etc.)


Reproducible: Always

Steps to Reproduce:
1. Drag a link from the location bar or web page to a bookmark toolbar folder.
2. Hold the link over the toolbar folder name.


Actual Results:  
Nothing.  The menu doesn't pop open to allow placement, nor is any feedback
provided to let the user know where the dragged item will be placed.


Expected Results:  
Menus and submenus on the bookmark toolbar should open to allow the user to
place dragged links in the desired position.  The toolbar itself and all
menus/submenus should provide clear feedback via highlighting or a
vertical/horiziontal cursor to indicate precisely where on the toolbar or menu
the link will appear when the mouse button is released.

Comment 1

13 years ago
(In reply to comment #0)
> This is further aggravated as the bookmark toolbar menu doesn't even give
> highlight feeback to show where a dragged link will be deposited (in a folder,
> on the toolbar itself, etc.)

Related to bug 235243?
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> 
> Related to bug 235243?

It does appear to be related, although that bug changed direction -- it appears
that a problem was identified (and fixed?) for Windows, but never addressed for
Mac OS X.  I'll note that this report highlights usability problems over and
above the simple lack of bookmark toolbar folders popping open.  These problems
are not addressed in bug 235243.

Comment 3

13 years ago
bug 299185 reads similar and perhaps this is a dup of 299185, unless it's
misplaced in product=core.
(Reporter)

Comment 4

13 years ago
(In reply to comment #3)
> bug 299185 reads similar and perhaps this is a dup of 299185

There is certainly overlap; I'd be willing to mark it as a dupe, except that bug
299185 doesn't address the related problem of a lack of visual feedback -- no
highlighting of the folder or toolbar location (w/ a vertical line) occurs in FF.  

Comment 5

13 years ago
Jesse is this confirmable, or is this a dup?

Comment 6

13 years ago
(In reply to comment #5)

> Jesse is this confirmable, or is this a dup?

I'd propose that we mark this as a dupe of bug #299185, but also file a new one
because there is no visible feedback from bookmark folders on the bookmark
toolbar when hovering over them in drag&drop mode (since this issue is listed in
this bug as well).

Comment 7

13 years ago
Created bug #311329 to deal with the visual feedback aspects of this report. We
are now free to mark this report as a dupe of bug #299185 which deals with the
folder expansion problem solely.

Comment 8

13 years ago

*** This bug has been marked as a duplicate of 299185 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.