A crash occurs when attempting to load a (640x480) 32 bit jpeg image

VERIFIED WORKSFORME

Status

()

Core
ImageLib
P3
critical
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: Chris Petersen, Assigned: pnunn)

Tracking

({crash, pp})

Trunk
PowerPC
All
crash, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Build: Apprunner
Version: 2000030208
Platform: Mac
Other Platforms: Works on Win 98 and Linux.

Expected Results: The image specified in the url should load and display in the 
browser window.

What I got: After typing the url and pressing return, the browser crashes.

Here is waht I got in Macsbug:

PowerPC unmapped memory exception at 06BFCDB0 find_temp_info+0000C


Steps to reproduce:

1) Launch apprunner.

2) Type the following url:

http://members.home.com/chowten/jeep/David_Driving.JPG

3) The browser will display the (640 x480 32 bit) image.

4) In the URL field, change the file name to David_Driving2.JPG and press return.

5) The application will attempt to load this image then crash.
(Reporter)

Updated

18 years ago
(Reporter)

Comment 1

18 years ago
*** Bug 30061 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 2

18 years ago
I'll look into it.
P
Status: NEW → ASSIGNED
Target Milestone: M14

Updated

18 years ago
Keywords: pp
Summary: [PP]A crash occurs when attempting to load a (640x480) 32 bit jpeg image → A crash occurs when attempting to load a (640x480) 32 bit jpeg image

Updated

18 years ago
Keywords: crash

Updated

18 years ago
Severity: normal → critical
(Assignee)

Comment 3

18 years ago
uh-oh. I got a 404 for the test url.
I'll keep trying.
-P
(Assignee)

Comment 4

18 years ago
ok. I have the directory now.
http://members.home.com/chowten/jeep/David_Driving.jpg
http://members.home.com/chowten/jeep/David_Driving2.jpg
http://members.home.com/chowten/jeep/David_Driving3.jpg
http://members.home.com/chowten/jeep/David_Driving4.jpg

all display on NT for me. I fixed the test url in bug report.

all display in viewer on mac from 03-16-2000 build.
all display in mozilla on mac from -3-16-2000 build.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 5

18 years ago
Verified as WORKSFORME on 3.28.00 builds on all platforms.
Status: RESOLVED → VERIFIED

Comment 6

13 years ago
http://www.justdave.net/dave/article.php?story=20050107003727277 -> Fixing
OS: All
You need to log in before you can comment on or make changes to this bug.