if css (stylesheet) href is empty, the current page is loaded again as a css file

RESOLVED INVALID

Status

()

Firefox
General
--
minor
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: Domonkos Körmendy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

If a page has an empty stylesheet href (<link rel="stylesheet" type="text/css"
href="" />), the current page is downloaded again, and used as a css file.
OK, this is an error in the html file, and the href is used as a relative link
to the current location (except when it begins with http://, etc.), but an empty
string could also mean: "no css file, please".
And if the page does some server side functions, it could be a bad thing to load
it two times.

Reproducible: Always

Steps to Reproduce:
1. create an html file with <link rel="stylesheet" type="text/css" href="" /> in
the head
2. view it

Actual Results:  
the page is downloaded two times, the second as the stylesheet file

Expected Results:  
the file should not load again as the stylesheet file (no css files should load)

Comment 1

13 years ago
Marking invalid.  href="" means the current document.  See comments in bug
225554 and bug 30817.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
*** Bug 352351 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.