[2005-07-12 Sunbird nightly] Assertion at startup

RESOLVED DUPLICATE of bug 265383

Status

RESOLVED DUPLICATE of bug 265383
14 years ago
13 years ago

People

(Reporter: sipaq, Assigned: mostafah)

Tracking

({smoketest})

Trunk
x86
Windows XP
smoketest

Details

(Reporter)

Description

14 years ago
When trying to start the 2005-07-12 Sunbird nightly on WinXP for the first time,
I get the following assertion:

###!!! ASSERTION: nsPrompt used too early on window object!:
'window->GetExtantDocument() != nsnull', file
c:/builds/tinderbox/Sb-Trunk/WINNT_5.2_Depend/mozilla/embedding/components/windowwatcher/src/nsPrompt.cpp,
line 168 Break: at file
c:/builds/tinderbox/Sb-Trunk/WINNT_5.2_Depend/mozilla/embedding/components/windowwatcher/src/nsPrompt.cpp,
line 168
(Reporter)

Updated

14 years ago
Summary: [2005-07-12 Sunbird nightly] Assertiong at startup → [2005-07-12 Sunbird nightly] Assertion at startup

Comment 1

14 years ago
Works for me in 2005-07-13 nightly for linux with clean profile or with old
data.  Maybe windows only?

(I do get a couple of other assertions, but nothing like this one.)
simon, are you still seeing this? I don't get it on linux, but it might be
windows specific.
And if it is, i think it's more an extension manager problem, as sunbird doesn't
prompt on startup. extmgr might to warn about disabled extensions.
(Reporter)

Comment 3

13 years ago
I don't see this on optimized builds. I can't say if it happens on debug builds,
since my build machine is down at the moment. Lowering severity.
Severity: blocker → normal

Comment 4

13 years ago
I get these assertions everytime I try to start a debug-build (this has been happening for weeks on cvs-builds): 

WARNING: NS_ENSURE_TRUE(nsDoc) failed, file d:/mozilla/mymoz/mozilla/content/xul
/content/src/nsXULElement.cpp, line 2299
###!!! ASSERTION: invalid active window: 'Error', file d:/mozilla/mymoz/mozilla/
embedding/components/windowwatcher/src/nsWindowWatcher.cpp, line 924
WARNING: NS_ENSURE_TRUE(vm) failed, file d:/mozilla/mymoz/mozilla/docshell/base/
nsDocShell.cpp, line 3712
WARNING: NS_ENSURE_TRUE(domdoc) failed, file d:/mozilla/mymoz/mozilla/xpfe/appsh
ell/src/nsXULWindow.cpp, line 1570
###!!! ASSERTION: invalid active window: 'Error', file d:/mozilla/mymoz/mozilla/
embedding/components/windowwatcher/src/nsWindowWatcher.cpp, line 924

Comment 5

13 years ago
(In reply to comment #4)

Looks like Bug 265383
(Reporter)

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 265383 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.