When browser.cache.disk.capacity=0, extensions fail to install.

RESOLVED DUPLICATE of bug 262854

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED DUPLICATE of bug 262854
13 years ago
10 years ago

People

(Reporter: dw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

It has taken me quite a while to work out the cause this problem. On all my
machines I keep the disk cache size set to 0kb for various reasons. When the
disk cache is set to 0kb, extenions will fail to install directly, unless I
first save them to my desktop and then drag them to the Firefox window.

On setting the cache to 512kb, installation starts to work correctly again.

Reproducible: Always

Steps to Reproduce:
1. Set browser cache size to 0kb and clear your cache (clearing might be optional)
2. Go to http://toolbar.google.com/firefox/extensions/suggest/install.html
3. Click 'Agree and install'.
4. Click 'install'.
5. Observe output in the attached screenshot.
Actual Results:  
"Because: download error" message appears.

Expected Results:  
Extension should be installed correctly, or alternatively an error indicating
that the extension installer cannot function unless disk cache is enabled should
be displayed.
(Reporter)

Comment 1

13 years ago
Created attachment 189175 [details]
screenshot of failure message.

Updated

13 years ago
Whiteboard: DUPEME

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 262854 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.