View source doesn't show source for automatic error pages. An error page is show instead.

VERIFIED DUPLICATE of bug 273968

Status

()

VERIFIED DUPLICATE of bug 273968
14 years ago
11 years ago

People

(Reporter: jorgev, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+

Deer Park features automatic error pages that show instead of the modal dialogs,
when there's a connection problem with a site, or under various circumstances.
The View Source feature for this pages seem broken, because it's showing an
error page on the View Source window instead of the page's source. I'm guessing
the View Source windows tries to obtain the source of the original site I was
trying to access instead of the generated page, which I'm not sure is proper
behavior.

Reproducible: Always

Steps to Reproduce:
1. Go to a page that fails due to connection problems or any other error that
shows an automatic error page.
2. Wait until error page appears.
3. Open View Page Source window (Ctrl+U).

Actual Results:  
An error page appears in the View Source window (the same that appeared in the
browser window, actuallly). I'll attach an image of the window.

Expected Results:  
The source of the generated error page should appear.

Selecting part of the error page content and selecting View Selection Source
does work properly.
(Reporter)

Comment 1

14 years ago
Created attachment 189183 [details]
View Source showing error page

This is a screenshot showing the View Source window with an error page, instead
of the expected code.

Comment 2

14 years ago
Reproducible with SeaMonkey/20050710 and Deer Park a2, related to Core bug 273968?

*** This bug has been marked as a duplicate of 273968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.