Closed Bug 300632 Opened 15 years ago Closed 15 years ago

Open in Tabs option should open bookmarks in new tabs

Categories

(Firefox :: Bookmarks & History, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 216346

People

(Reporter: jorgev, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b3) Gecko/20050710 Firefox/1.0+

When I select the Open in Tabs context option in a bookmarks folder, the tabs
currently opened are used for the bookmarks as well, completely changing the
state of my browser. IMO choosing Open in Tabs should not disrupt current
navigation, and should open all in new tabs to avoid this.

Reproducible: Always

Steps to Reproduce:
1. Open a couple of tabs as if navigating normally. (Let's say mozilla.org and
google.com)
2. Select the Open in Tabs option on a bookmarks folder that has 2 or more
bookmarks.

Actual Results:  
The current tabs (mozilla.org and google.com) navigate to the first bookmarks on
the folder, and new tabs are opened for the remaining bookmarks, if there's any.

Expected Results:  
The current tabs should remain, and the bookmars on the folder should open in
new tabs.

I looked for a duplicate but I couldn't find one, eventhough there's a brief
discussion of this on Bug 227388.

*** This bug has been marked as a duplicate of 216346 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.