::first-letter isn't applied if inside <a> and <a> has been hovered over

RESOLVED DUPLICATE of bug 23604

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 23604
13 years ago
13 years ago

People

(Reporter: Brandon Harvey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5

The following html and css code writes out a "Research Paper Title" where the
first letter (the letter R) is colored firebrick red, and the rest is silver. 
When hovered over, the entire title is colored firebrick red (correct behavior).
 But when the mouse rolls off the title again, the first letter is no longer red
-- it is silver.  The first-letter property has been lost.

.head2text:first-letter { color: firebrick; }
a:link{	color: silver;}
a:visited{	color: silver;}
a:active{color: silver;}
a:hover {color: firebrick;}

<div class="head2text">
  <a href="papers/paper.pdf">Research Paper Title</a>
</div>


Reproducible: Always

Steps to Reproduce:
1.create an html page that incorporates the code above
2.see that the first letter is correctly red
3.hover over the link.  then roll off of it.
4.see that the first letter is no longer red

Actual Results:  
the first letter of "Research Paper Title" is no longer red.

Expected Results:  
The first letter of "Research Paper Title" should be re-colored red after the
mouse rolls off of the title.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 23604 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.