does not delete downloading file when download is cancelled by closing download and firefox window

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
--
enhancement
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Scott, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

When I start downloading a file, and I close the download and the Firefox
window, the window pops up asking if I want to cancel the download.  If I hit to
cancel it, the download is stopped, but the file remains on the hard drive. 

But, the good thing about this is that it can 'suspend' a download if you try
downloading the same file to the same location.  This is because it just
continues where the last download left off.  This is a request not to eradicate
this, but to make a feature in the download manager that can do the same thing,
pause a download to be continued later.  This can be a big help for dial-up
users like myself.

Reproducible: Always

Steps to Reproduce:
1. In Firefox, begin a download.
2. Close both the firefox window and download window.
3. When the window pops up about cancelling the download, cancel it.
4. Re-open Firefox and start downloading the same file to the same location.

Actual Results:  
The download is continued from where it left off.

Expected Results:  
The download should have started over because the previous download should have
been deleted when cancelled.

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 251625 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 2

12 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
ID:2005071214

Well, this seems to be a totally different bug. I can confirm this behavior on
Linux. The .part file is removed, but the original file still remains. I don't
know if this is the expected behavior or not, so I'm leaving this as UNCONFIRMED.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

12 years ago
I've followed the following steps exactly and cannot reproduce this issue:

1. In Firefox, begin a download.
2. Close both the firefox window and download window.
3. When the window pops up about cancelling the download, cancel it.
4. Re-open Firefox and start downloading the same file to the same location.

Actual Results:  
The download started over (from the beginning) BUT the previous
cancelled/incomplete download WAS NOT DELETED!!!

Expected Results:  
The download starts over (from the beginning) AND the previous
cancelled/incomplete download should have been deleted by the previous
cancellation of the prior download.

Comment 4

12 years ago
Ok, here's some detail on the bug.

It only happens if you close firefox first. 
It does not happen if you click cancel next to the specific download

Normally while a download is in progress you will have a download.zip and
download.part file.
(filenames are only examples, they could be anything)

To repruduce this bug, close firefox, and click the X in upper right of firefox
window.
It prompt you with a window "If you exit now, 1 download will be canceled. Are
you sure you want to exit?"
If you pick the button "Cancel 1 download" it will delete the download.part file
but it will NOT delete the download.zip file

My theory: When I try to delete the file manually in windows after closing
firefox and download window (making sure they are closed in windows task
manager), it says its in use and cannot be deleted. I'm guessing a filehandle is
left open somewhere and firefox fails on the delete but doesn't notify you.

Comment 5

11 years ago
I have had the same problem, I still have a file on my desktop from a download 6 weeks ago and cannot delete the file. How can I remove this file ?????


(In reply to comment #4)
> Ok, here's some detail on the bug.
> 
> It only happens if you close firefox first. 
> It does not happen if you click cancel next to the specific download
> 
> Normally while a download is in progress you will have a download.zip and
> download.part file.
> (filenames are only examples, they could be anything)
> 
> To repruduce this bug, close firefox, and click the X in upper right of firefox
> window.
> It prompt you with a window "If you exit now, 1 download will be canceled. Are
> you sure you want to exit?"
> If you pick the button "Cancel 1 download" it will delete the download.part file
> but it will NOT delete the download.zip file
> 
> My theory: When I try to delete the file manually in windows after closing
> firefox and download window (making sure they are closed in windows task
> manager), it says its in use and cannot be deleted. I'm guessing a filehandle is
> left open somewhere and firefox fails on the delete but doesn't notify you.

Updated

10 years ago
Duplicate of this bug: 392592
Blocks: 392592
The request in comment 1 is actually implemented in trunk now for download that we can resume.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.