Right-clicking a bookmark in a subfolder and clicking outside the Bookmarks menu blocks access to that folder.

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
--
major
RESOLVED INVALID
13 years ago
13 years ago

People

(Reporter: pile0nades, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.9) Gecko/20050711 Firefox/1.0.5 - Build ID: 2005071118

In the Bookmarks menu, if you right-click on a bookmark which is in a subfolder
to bring up the context menu (which is empty, wtf?), then click outside the
Bookmarks menu, you can no longer access the subfolder of the bookmark you
right-clicked. 

Reproducible: Always

Steps to Reproduce:
1. Open a subfolder in the Bookmarks menu.
2. Right-click a Bookmark in it.
3. Click outside the Bookmarks menu.
4. Try to open the same subfolder. You cannot do so.
5. To regain access to the subfolder you must restart Firefox.
Actual Results:  
The subfolder refused to open.

Expected Results:  
The subfolder should have opened.

The bug occurs in safe mode.
(Reporter)

Comment 1

13 years ago
Screenshot in this thread:

http://forums.mozillazine.org/viewtopic.php?t=283025

Comment 2

13 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8b3) Gecko/20050712 Firefox/1.0+
ID:2005071214

Works for me.

In the screenshot, you're using an theme. You need to test this with a new
profile. This issue seems to have been fixed in bug 234717 and bug 210910, so it
probably has to do with the theme you're using. 

(Reporter)

Comment 3

13 years ago
I created a new profile and the bug does not occur. But then why does it happen
in safemode? What is the difference between a new profile and safemode?
(In reply to comment #3)
> I created a new profile and the bug does not occur. But then why does it happen
> in safemode? What is the difference between a new profile and safemode?

Are you sure your were in safe mode (it should default to the default theme),
you need to close all active firefox processes before starting safe mode.
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> Are you sure your were in safe mode (it should default to the default theme),
> you need to close all active firefox processes before starting safe mode.

Yes. I closed Firefox and checked the processes tab in the Ctrl-Alt-Del dialog
and there were no Firefox processes running. I click the Safe Mode shortcut in
the Start menu and it defaults to the default theme and no extensions are
active. I don't see why it would be any different than a new profile... Hold up.
In Safe Mode I still have my same options in the Options dialog.

It must be something in about:config.

Comment 6

13 years ago
Yes. It's most likely that an extension you installed editing an about:config
entry, and that would not be changed when you enter safe-mode. I'm marking this
as INVALID per reporter's comment's 3 and 5.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.